Bug 100015 - Unary and Binary Operators images missing
Summary: Unary and Binary Operators images missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.4.0 target:5.3....
Keywords:
: 104752 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-23 16:22 UTC by Samson
Modified: 2016-12-29 10:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Unary and Binary Operators (166.96 KB, image/png)
2016-05-23 16:22 UTC, Samson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samson 2016-05-23 16:22:47 UTC
Created attachment 125247 [details]
Unary and Binary Operators

LibreOfice 5.1.3.2 I am using the Amharic Translation version 

In Help page If you go to the Index and find "Unary and Binary Operators" highlight and press enter you will see a chart some of them I can't see them 

Thanks 
Samson
Comment 1 Buovjaga 2016-05-27 10:56:34 UTC
Confirmed.

64-bit, KDE Plasma 5
Build ID: 5.1.3.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Gabor Kelemen 2016-09-27 20:51:46 UTC
This problem affects more than one page.

In the offline help all pages under "Formula Reference Tables" and "Elements" pages (on "Welcome to the LibreOffice Math Help") have a lot of missing images.
 
The online help is fine:
https://help.libreoffice.org/Math/Formula_Reference_Tables
https://help.libreoffice.org/Math/Elements

Most of the images referenced on these pages are present in icon-themes/galaxy/starmath/res but not packaged into the theme zip file.

The Unary and Binary Operators page has a bit different problem: the images referenced are not present in the Galaxy theme only in the Elementary theme. To me they look rather theme neutral, so maybe we could just move the un21*png files from icon-themes/elementary/starmath/res to Galaxy.
 
One solution could be to move the images over to icon-themes/galaxy/res/helpimg where they would get automatically packaged and modify the xhp files to link to this new location. I already have a patch for this.

This would require similar image moves in the human, elementary, hicontrast and oxygen themes as well.
Comment 3 Commit Notification 2016-09-28 13:21:41 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=112cf7c587ffbfb442148e1d49d3638596b91615

tdf#100015 (related) New image locations in Math help
Comment 4 Commit Notification 2016-09-28 21:53:41 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f6f851acab5284f516ad6a91c05149ffed575d2

tdf#100015 (related) Move Math help icons to correct location

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2016-11-08 08:57:22 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 6 Commit Notification 2016-11-23 15:46:13 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b5c453ba08fec648207547b3d34f9d49b5924dc

tdf#100015 Move unary and binary operators icons to Galaxy

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-11-23 15:47:04 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=edf19a7a141e1be811be43fab68d630653b9f8c2

tdf#100015 Fix icon paths on the unary and binary operators pages
Comment 8 Samson 2016-11-23 17:19:31 UTC
Hello

I download and install libreoffice 5.3 on Saturday and the problem didn't change. when is it fixed. please check it again.

From which version is 5.3 is created? I have seen you add some new future and when I check them they are translated but they show as not translated.
I think all version are not synchronized the reason why I said this is because

If you see the Amharic 5.0 Help it says 24% translated and 75% Untranslated 
If you see the Amharic 5.1 Help it says 49% translated and 51% Untranslated 
If you see the Amharic 5.2 Help it says 93% translated and 7% Untranslated 
If you see the Amharic Master it says 99% translated and 1% Untranslated 
and please upgrade every thing. there are many changes that I have made.


Thanks
Samson
Comment 9 Buovjaga 2016-11-23 18:09:28 UTC
(In reply to Samson from comment #8)
> Hello
> 
> I download and install libreoffice 5.3 on Saturday and the problem didn't
> change. when is it fixed. please check it again.

Gabor just pushed a fix today, so you have to try with a fresh build tomorrow (or do a build yourself right now).
Comment 10 Commit Notification 2016-12-14 22:10:34 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0071169e7197c8c00155fc30c0c6ce4b0e17afd4

tdf#100015 Last missing icon moved from elementary set

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Gabor Kelemen 2016-12-19 08:37:35 UTC
*** Bug 104752 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2016-12-20 21:32:38 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53a3a4a7ce2f7e55615f186c06ec565232f655fd&h=libreoffice-5-3

tdf#100015 Last missing icon moved from elementary set

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-12-21 23:28:26 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e511aad844fd2fa16077db4d11311b5710f45b64&h=libreoffice-5-3

tdf#100015 Fix icon paths on the unary and binary operators pages
Comment 14 Commit Notification 2016-12-27 14:38:03 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1de21dc3800917ada88b38c781b85940a7703ee&h=libreoffice-5-3

tdf#100015 Move unary and binary operators icons to Galaxy

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Gabor Kelemen 2016-12-29 10:01:02 UTC
Verified with a fresh build of the 5-3 branch, with the latest patch there are no more missing images in the formula editor help.