Download it now!
Bug 100036 - Phantom rows appear only when exporting to PDF (not when printing or editing)
Summary: Phantom rows appear only when exporting to PDF (not when printing or editing)
Status: RESOLVED DUPLICATE of bug 54908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-24 19:27 UTC by Jim Avera
Modified: 2016-05-26 17:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet with phantom rows visible only when exporting to PDF (19.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-24 19:27 UTC, Jim Avera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2016-05-24 19:27:22 UTC
Created attachment 125262 [details]
Spreadsheet with phantom rows visible only when exporting to PDF

This is wierd. The attached spreadsheet has been edited down to have only two pages of content.  I did select-all,Format->Row->Show to un-hide any hidden rows, and similarly for columns.  Only the expected two pages of content are visible, and when printed that's only what is printed.  Fine so far.

But exporting to PDF appends hundreds of rows of phantom content.  It is content which I thought I had deleted or replaced with new cell values.

Again, the phantom content is completely invisible when editing or printing.  It only appears when exporting to PDF.

STEPS TO REPRODUCE:

1. Load the attached phantomrows.ods
2. Print-preview; verity that only two pages appear
3. File->Export to PDF
4. Open the resulting PDF

RESULTS: Lots of mysterious junk after the expected rows

EXPECTED RESULTS: Export to PDF should produce the same as Print;
   Also, deleted content should actually be deleted, and if any rows
   are hidden they should be un-hidden by selecting the range and
   doing Format->Row->Show.
Comment 1 Jim Avera 2016-05-24 19:32:09 UTC
FWIW, this spreadsheet was originally imported from .xlsx written by Excel
Comment 2 m.a.riosv 2016-05-24 23:45:26 UTC
Hi Jim,

select in first screen of Export to PDF 'Selection', otherwise everything is exported.

Resolved as duplicate, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 54908 ***
Comment 3 Jim Avera 2016-05-25 17:54:25 UTC
AFAIK this has nothing to do with selections.  Reopening.
Comment 4 Aron Budea 2016-05-26 06:51:52 UTC
Jim, the "mysterious junk" is the second sheet in your spreadsheet.
What Miguel meant is that if in PDF Options... dialog you change Range option to Selection, only the selected sheet will be exported.
Similarly, if in Print dialog you change Range and Copies option to All sheets, you will see the same result as your initial PDF export.
Comment 5 Jim Avera 2016-05-26 17:19:40 UTC
Ok, I understand now.  Thanks for your persistence.

It would be nice if PDF and Print dialogs had exactly the same default settings!

*** This bug has been marked as a duplicate of bug 54908 ***