Bug Hunting Session
Bug 100073 - Last line on page is only partially shown in docx document
Summary: Last line on page is only partially shown in docx document
Status: RESOLVED DUPLICATE of bug 101627
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-05-26 19:56 UTC by Oliver Sander
Modified: 2019-09-11 08:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The docx file in question (83.83 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-05-26 19:56 UTC, Oliver Sander
Details
The document as shown by MSOffice 2010 (60.80 KB, application/pdf)
2016-05-26 19:57 UTC, Oliver Sander
Details
The document as shown by LibreOffice 5.1.3 (97.51 KB, application/pdf)
2016-05-26 19:57 UTC, Oliver Sander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Sander 2016-05-26 19:56:37 UTC
Created attachment 125305 [details]
The docx file in question

I have a letter template from my university administration in docx format, which looks slightly different in MSOffice 2010 and LibreOffice 5.1.3.  In particular, LibreOffice shows only the upper half of the last line of text.

Example documents are attached.  The document actually shows four different problems; I will open separate bugs for the other three.

Thanks for your consideration.
Comment 1 Oliver Sander 2016-05-26 19:57:06 UTC
Created attachment 125306 [details]
The document as shown by MSOffice 2010
Comment 2 Oliver Sander 2016-05-26 19:57:28 UTC
Created attachment 125307 [details]
The document as shown by LibreOffice 5.1.3
Comment 3 Buovjaga 2016-05-27 15:03:40 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 60041cb237ea73c2c1885dd6afd99d88780c2dfc
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on May 26th 2016
Comment 4 Oliver Sander 2016-10-21 16:31:55 UTC
Reproduced in

LibreOfficeDev 5.3.0.0.alpha1 f4ca1573fcf445164c068c1046ab5d084e1b005f
Debian Testing, Mate Desktop


Actually, it even got a little worse.  Unlike previous versions, LibreOffice5.3 now breaks the line between "elektronische" and "Dokumente".
Comment 5 Patrick Jaap 2017-04-18 07:32:07 UTC
This bug a duplicate of 
https://bugs.documentfoundation.org/show_bug.cgi?id=101627
which is solved.
Comment 6 Patrick Jaap 2017-04-18 07:32:26 UTC

*** This bug has been marked as a duplicate of bug 101627 ***
Comment 7 Timur 2019-09-11 07:58:28 UTC
Footer text "Kein Zugang für elektronisch signierte sowie verschlüsselte elektronische Dokumente" is, as other text, font "Univers 45 Light" bold italic in MSO.

LO doesn't have that font and it replaces it. Not shown with which font, bug 61134. 
Replacement is not adequate, which is in general bug 64509. Recommended replacements are non-free: http://www.identifont.com/similar?X6. Other possibilities are Open Sans or Milford.
Seems that previous replacement as shown in attachment 125307 [details] was better than the current in LO 6.4+. And that seems like an issue that I'll mention in bug 64509. 

Footer box with "Zufahrt Heckelstraße Willersbau C-Flügel" opens wrongly as TNR 12 in LO. In MSO it's also "Univers 45 Light" 7.
Comment 8 Timur 2019-09-11 08:06:20 UTC
(In reply to Timur from comment #7)
> Seems that previous replacement as shown in attachment 125307 [details] was
> better than the current in LO 6.4+. 
Yes, attachment 125307 [details] looked OK with font replacement but when I myself tested LO 5.1 it looks the same as LO 6.4+, with inadequate font substitute. I can't say why. So I will not mention this is font substitute bug.