Bug Hunting Session
Bug 100208 - UI languages mixed
Summary: UI languages mixed
Status: RESOLVED DUPLICATE of bug 94090
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.0.6.2 rc
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-03 18:25 UTC by Timur
Modified: 2017-06-22 13:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
UI languages mixed (797.49 KB, image/png)
2016-06-03 18:25 UTC, Timur
Details
UI languages mixed on right click (26.96 KB, image/jpeg)
2016-06-06 09:25 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-06-03 18:25:08 UTC
Created attachment 125472 [details]
UI languages mixed

As shown in the attachment, there are at least 3 UI languages in the same dialog in Writer 5.0.6: English, Bosnian, and some unknown.
In a "better" case, there are 2 languages mixed: English, Bosnian.
Deleting profile doesn't help.
Installation was a centralized upgrade to dozen of various Windows computers (XP, 7, 10) from LO 5.0.5 to LO 5.0.6. Only some have this problem.
Comment 1 Adolfo Jayme 2016-06-03 21:45:48 UTC

*** This bug has been marked as a duplicate of bug 96942 ***
Comment 2 Aron Budea 2016-06-04 00:13:16 UTC
Adolfo, I'm not sure the two bugs are related (bug 94090 looks like a candidate, though). This seems to be a corrupt installation/upgrade, as normally the texts are translated in that dialog.
I did an 5.0.5.2 install, and then upgraded to 5.0.6.3, but the particular dialog appeared properly translated.

My assumption is if the user profile is fine, then something must be wrong with the installed files. Timur, can you look into it what is different in those installs where the language is wrong compared to where it's right? Comparing checksums of all the installed files in the Program Files directory to find differences should give some clues.
Comment 3 Timur 2016-06-06 09:25:31 UTC
Created attachment 125507 [details]
UI languages mixed on right click
Comment 4 Timur 2016-06-06 09:25:44 UTC

*** This bug has been marked as a duplicate of bug 94090 ***