Bug 100215 - Cropped images corrupted when reopening the Slidedeck
Summary: Cropped images corrupted when reopening the Slidedeck
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.6.2 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss, regression
: 100216 (view as bug list)
Depends on:
Blocks: Image-Crop
  Show dependency treegraph
 
Reported: 2016-06-04 11:44 UTC by Aurélien Pupier
Modified: 2018-07-12 12:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
see slides 7 or 13 (1.57 MB, application/vnd.oasis.opendocument.presentation)
2016-06-04 11:44 UTC, Aurélien Pupier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien Pupier 2016-06-04 11:44:17 UTC
Created attachment 125480 [details]
see slides 7 or 13

- create a slides
- do a screnshot
- Paste it in the Impress
- Crop the image
- close Impress
- reopen
--> all the cropped images are corrupted!

I'm on Windows 10 with Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: en-US (en_US)
Comment 1 Julien Nabet 2016-06-04 11:59:24 UTC
*** Bug 100216 has been marked as a duplicate of this bug. ***
Comment 2 Buovjaga 2016-06-09 17:13:44 UTC
Yes, their height gets squashed a bit (reproduced).

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 2d2a33934ecb952433a635ce5dab76cb2837b8a0
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 9th 2016
Comment 3 Buovjaga 2018-03-08 12:49:30 UTC
Did a new test from scratch and still the crop behaves funnily. This time the crop area moved and height became greater.

However, this does not happen in 3.6.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: b8fe96f1da2c42c04a8094ca8c57d49763b7bded
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on March 8th 2018

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Buovjaga 2018-06-02 14:54:44 UTC
Tested with 6.0.4 and master on Win (from scratch), but there was no problem.

Aurélien: can you do a test from scratch?
Comment 5 Buovjaga 2018-07-12 12:46:30 UTC
(In reply to Buovjaga from comment #4)
> Tested with 6.0.4 and master on Win (from scratch), but there was no problem.
> 
> Aurélien: can you do a test from scratch?

No reply in over a month, so closing as WFM.