Bug 100225 - crash when extending area
Summary: crash when extending area
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: profile
Keywords:
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2016-06-05 15:42 UTC by Toby
Modified: 2018-02-26 11:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File showing crash (17.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-06-05 15:44 UTC, Toby
Details
registrymodifications.xcu needed for crash (deleted)
2016-06-05 17:31 UTC, Toby
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toby 2016-06-05 15:42:27 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36
Build Identifier: LibreOffice 5.0.6.3

I have a document with various formulae. If I select one line and extend the region to cover the next line, calc crashes.

Reproducible: Always

Steps to Reproduce:
1. Load attached file
2. Select Yellow area
3. Click on dot on bottom right of area and drag to extend area to cover the blue area
4. Crashes
Actual Results:  
Crash

Expected Results:  
Replace the 2nd line (blue) with formulae from the 1st line (yellow)

[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Toby 2016-06-05 15:44:07 UTC
Created attachment 125493 [details]
File showing crash

Please use this file to recreate the crash
Comment 2 m.a.riosv 2016-06-05 15:52:36 UTC
Hi @Toby, thanks for reporting.

I can't reproduce.
Win10x64
Version: 5.0.6.2 (x64)
Build ID: b3fbfa99158a1030fb79f0ba72b6851afc3c7895-GL
Version: 5.1.4.1 (x64)
Build ID: a4d48e4ff0e9f93e78b6356ca7b0b6303e360356
CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
Locale: es-ES (es_ES)

Please test:
¬ Disabling Menu/Tools/Options/LibreOffice/View - Use OpenGL (restart)
¬ Disabling Menu/Tools/Options/LibreOffice/OpenCL, bot options (restart).

if it doesn't solves the issue, please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 3 Toby 2016-06-05 17:29:05 UTC
Thanks for looking at this.
I renamed registrymodifications.xcu and the file worked correctly.
I deleted the new version and replaced with the old and the file crashes.
I will attach the 'bad' version of registrymodifications.xcu if you wish to review it.
Comment 4 Toby 2016-06-05 17:31:00 UTC
Created attachment 125497 [details]
registrymodifications.xcu needed for crash

This is the registrymodifications.xcu file which I had when I experienced the crash.
Deleting it allowed calc to work correctly, replacing it allowed the crash again.
Comment 5 m.a.riosv 2016-06-05 20:58:55 UTC
Thanks Toby for attach the file, added 'profile' to Whiteboard.
Comment 6 Xisco Faulí 2018-02-26 11:05:57 UTC
The content of attachment 125497 [details] has been deleted