Bug 100239 - UI Blinking thumbnails of linked images
Summary: UI Blinking thumbnails of linked images
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks: Impress-Images
  Show dependency treegraph
 
Reported: 2016-06-06 14:26 UTC by Ilario Gelmetti
Modified: 2019-02-24 20:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Blinking thumbnails of linked images in LibreOffice Impress (118.36 KB, image/jpeg)
2016-06-06 14:26 UTC, Ilario Gelmetti
Details
an impress document inducing bug 100239 (16.17 KB, application/vnd.oasis.opendocument.presentation)
2016-06-18 22:00 UTC, ange.nizard
Details
impress test file that bring out the bug with 5.2.beta2 and 5.1.4.2 (16.84 KB, application/vnd.oasis.opendocument.presentation)
2016-06-19 07:48 UTC, ange.nizard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilario Gelmetti 2016-06-06 14:26:18 UTC
Created attachment 125515 [details]
Blinking thumbnails of linked images in LibreOffice Impress

Hi!
I'm using Impress 5.1.3.2 and linking more than an image for slide.
In the left column I can see the images thumbnail starting blinking in an alternate fashion between the correct thumbnail and a rectangle with a tiny red text. Usually just the upper slide present in the left column is the one with blinking thumbnails. Obviously this makes LibreOffice Impress harvest a lot of CPU.
To reproduce this you can create a presentation and start inserting two linked images for each slide, adding more slides at some point the thumbnails should start blinking.
See image.
In the image you can notice that also many other thumbnails are broken but at least they're static.



-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (980, 'testing'), (900, 'stable'), (200, 'unstable'), (100, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 4.2.0-1-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libreoffice-impress depends on:
ii  dpkg                      1.18.7
ii  libc6                     2.22-9
ii  libetonyek-0.1-1          0.1.6-2
ii  libgcc1                   1:6.1.1-4
ii  libgl1-mesa-glx [libgl1]  11.2.2-1
ii  libglew1.13               1.13.0-2
ii  libglu1-mesa [libglu1]    9.0.0-2.1
ii  libmwaw-0.3-3             0.3.7-1
ii  libodfgen-0.1-1           0.1.6-1
ii  libreoffice-core          1:5.1.3-2
ii  libreoffice-draw          1:5.1.3-2
ii  librevenge-0.0-0          0.0.4-4
ii  libstdc++6                6.1.1-4
ii  libxml2                   2.9.3+dfsg1-1
ii  uno-libs3                 5.1.3-2
ii  ure                       5.1.3-2
ii  zlib1g                    1:1.2.8.dfsg-2+b1

Versions of packages libreoffice-impress recommends:
ii  libreoffice-avmedia-backend-gstreamer  1:5.1.3-2

Versions of packages libreoffice-impress suggests:
ii  bluez  5.36-1+b1

Versions of packages libreoffice-core depends on:
ii  fontconfig                2.11.0-6.4
ii  fonts-opensymbol          2:102.7+LibO5.1.3-2
ii  libboost-date-time1.58.0  1.58.0+dfsg-5+b1
ii  libc6                     2.22-9
ii  libcairo2                 1.14.6-1+b1
ii  libclucene-contribs1v5    2.3.3.4-4.1
ii  libclucene-core1v5        2.3.3.4-4.1
ii  libcmis-0.5-5v5           0.5.1-4
ii  libcups2                  2.1.3-5
ii  libcurl3-gnutls           7.47.0-1
ii  libdbus-1-3               1.10.8-1
ii  libdbus-glib-1-2          0.106-1
ii  libdconf1                 0.26.0-1
ii  libeot0                   0.01-3
ii  libexpat1                 2.1.1-2
ii  libexttextcat-2.0-0       3.4.4-1
ii  libfontconfig1            2.11.0-6.4
ii  libfreetype6              2.6.3-3+b1
ii  libgcc1                   1:6.1.1-4
ii  libgl1-mesa-glx [libgl1]  11.2.2-1
ii  libglew1.13               1.13.0-2
ii  libglib2.0-0              2.48.1-1
ii  libgltf-0.0-0v5           0.0.2-4+b1
ii  libglu1-mesa [libglu1]    9.0.0-2.1
ii  libgraphite2-3            1.3.8-1
ii  libharfbuzz-icu0          1.2.6-2
ii  libharfbuzz0b             1.2.6-2
ii  libhunspell-1.4-0         1.4.1-2
ii  libhyphen0                2.8.8-3
ii  libice6                   2:1.0.9-1+b1
ii  libicu55                  55.1-7
ii  libjpeg62-turbo           1:1.4.2-2
ii  liblangtag1               0.5.7-2
ii  liblcms2-2                2.7-1
ii  libldap-2.4-2             2.4.42+dfsg-2+b2
ii  libmythes-1.2-0           2:1.2.4-1
ii  libneon27-gnutls          0.30.1-3
ii  libnspr4                  2:4.12-2
ii  libnss3                   2:3.23-2
ii  libnss3-1d                2:3.23-2
ii  libodfgen-0.1-1           0.1.6-1
ii  libpcre3                  2:8.38-3.1
ii  libpng16-16               1.6.21-5
ii  librdf0                   1.0.17-1+b1
ii  libreoffice-common        1:5.1.3-2
ii  librevenge-0.0-0          0.0.4-4
ii  libsm6                    2:1.2.2-1+b1
ii  libssl1.0.2               1.0.2h-1
ii  libstdc++6                6.1.1-4
ii  libx11-6                  2:1.6.3-1
ii  libxext6                  2:1.3.3-1
ii  libxinerama1              2:1.1.3-1+b1
ii  libxml2                   2.9.3+dfsg1-1
ii  libxrandr2                2:1.5.0-1
ii  libxrender1               1:0.9.9-2
ii  libxslt1.1                1.1.28-4
ii  uno-libs3                 5.1.3-2
ii  ure                       5.1.3-2
ii  zlib1g                    1:1.2.8.dfsg-2+b1

Versions of packages libreoffice-draw depends on:
ii  dpkg                1.18.7
ii  libavahi-client3    0.6.32~rc+dfsg-1
ii  libavahi-common3    0.6.32~rc+dfsg-1
ii  libc6               2.22-9
ii  libcdr-0.1-1        0.1.2-2
ii  libdbus-1-3         1.10.8-1
ii  libdbus-glib-1-2    0.106-1
ii  libfreehand-0.1-1   0.1.1-1
ii  libgcc1             1:6.1.1-4
ii  libglib2.0-0        2.48.1-1
ii  libicu55            55.1-7
ii  liblcms2-2          2.7-1
ii  libmspub-0.1-1      0.1.2-2+b1
ii  libmwaw-0.3-3       0.3.7-1
ii  libodfgen-0.1-1     0.1.6-1
ii  libpagemaker-0.0-0  0.0.3-1
ii  libreoffice-core    1:5.1.3-2
ii  librevenge-0.0-0    0.0.4-4
ii  libstdc++6          6.1.1-4
ii  libvisio-0.1-1      0.1.5-1
ii  libwpd-0.10-10      0.10.1-1
ii  libwpg-0.3-3        0.3.1-1
ii  libxml2             2.9.3+dfsg1-1
ii  uno-libs3           5.1.3-2
ii  ure                 5.1.3-2
ii  zlib1g              1:1.2.8.dfsg-2+b1
Comment 1 Buovjaga 2016-06-10 11:41:51 UTC
I added 4 images as links to one slide.
Saved and reloaded.
Still no blinking.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 2d2a33934ecb952433a635ce5dab76cb2837b8a0
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 9th 2016
Comment 2 raal 2016-06-10 15:00:03 UTC
No repro with Version: 5.3.0.0.alpha0+
Build ID: 86d84ae4bba0d4c45bc13232645318291a8aed75
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-05-26_14:33:24

Please attach test files - images. Thanks
Comment 3 ange.nizard 2016-06-18 16:32:03 UTC
Hi, same problem here.

Impress 4.4.6.3
Build ID: 40m0(Buld:3)
Locale: fr_FR.UTF-8
OS: Xubuntu 15.04 64-bit; CPU Threads: 8

Blinking of linked images in the slide pane is triggered each time a slide is inserted (new or duplicate), moved (drag-drop), removed or when the document is loaded.

Images in a thumbnail stop blinking when the thumbnail is selected.
Blinking often propagates to the images of the next thumbnail, down to the last one.

While blinking, about 3 CPU threads are mobelized which yields to a very laggy UI. Then, if different thumbnails are selected too quickly, undesired slide duplicates are generated.

The red text appearing is the path to the corresponding blinking image.

This is systematic.
Comment 4 Buovjaga 2016-06-18 16:57:39 UTC
(In reply to ange.nizard from comment #3)
> Hi, same problem here.

Test file, plz.
Comment 5 ange.nizard 2016-06-18 22:00:37 UTC
Created attachment 125727 [details]
an impress document inducing bug 100239

The image linked in this impress document is the one previously provided as an illustration for this bug: "libreoffice-bug.jpg"
Comment 6 Buovjaga 2016-06-19 06:46:20 UTC
(In reply to ange.nizard from comment #5)
> Created attachment 125727 [details]
> an impress document inducing bug 100239
> 
> The image linked in this impress document is the one previously provided as
> an illustration for this bug: "libreoffice-bug.jpg"

Thanks. I confirm with 5.1.3 BUT not with 5.3 :)

Can you guys please test with 5.1.4 and maybe 5.2 release candidates?
http://www.libreoffice.org/download/pre-releases/

64-bit, KDE Plasma 5
Build ID: 5.1.3.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: c13f60e7cd18df6b0ab70289f5b91ee01e4ae126
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 18th 2016
Comment 7 ange.nizard 2016-06-19 07:48:14 UTC
Created attachment 125730 [details]
impress test file that bring out the bug with 5.2.beta2 and 5.1.4.2

with versions 5.2.0.0.beta2 and 5.1.4.2 the bug is harder to reproduce but occurred eventually (17 slides or so)
Comment 8 Buovjaga 2016-06-19 09:49:22 UTC
(In reply to ange.nizard from comment #7)
> Created attachment 125730 [details]
> impress test file that bring out the bug with 5.2.beta2 and 5.1.4.2
> 
> with versions 5.2.0.0.beta2 and 5.1.4.2 the bug is harder to reproduce but
> occurred eventually (17 slides or so)

Ok, what I'm seeing with 5.3 when moving a slide is that LibO does an unneeded refresh of all the slide thumbs. It does not go into a loop, but for sure we can save some CPU cycles, if we skip this.
Comment 9 lj308 2017-04-15 21:53:50 UTC
I'm seeing this same problem with LibreOffice Draw version 5.3.2.1 on Slackware Linux 14.2 using the official LibreOffice builds for Linux.  Thumbnails blink alternating for each slide with linked images. Clicking on the thumbnails slowly, one after the other, stops the blinking. They will restart blinking if I select a different slide master for a slide.

(Adding this comment because above comments imply it is OK in 5.3. It isn't, at least not in Draw. Should I instead open a new report on Draw, vs Impress?)
Comment 10 Buovjaga 2017-04-16 06:37:21 UTC
(In reply to lj308 from comment #9)
> (Adding this comment because above comments imply it is OK in 5.3. It isn't,
> at least not in Draw. Should I instead open a new report on Draw, vs
> Impress?)

No, Draw and Impress share a lot of code.

Can you confirm they do not blink in 5.0 or some older version? https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 11 lj308 2017-04-18 21:41:32 UTC
(In reply to Buovjaga from comment #10)
> Can you confirm they do not blink in 5.0 or some older version?
I can confirm they do in fact blink in 5.0.6.3 Draw, so this is apparently not a new problem.
Comment 12 QA Administrators 2018-04-20 02:33:48 UTC Comment hidden (obsolete)
Comment 13 lj308 2019-02-24 20:17:13 UTC
I did see the problem in Draw 5.4.6, when the previous comment from the QA team was posted. But now I am now using Draw 6.1.5 and the problem seems to have been completely fixed. No evidence of blinking or vanishing thumbnails with linked images.
Comment 14 lj308 2019-02-24 20:20:44 UTC
I see the QA instructions say I should have changed the status to RESOLVED-WORKSFORME, but I didn't. Although it works for me, I don't know if it works for anyone else, or in particular for the bug author.
Comment 15 Buovjaga 2019-02-24 20:33:28 UTC
lj308: as you still saw the problem as recently as 5.4, I am pretty confident we can close this. Thanks for following up.