Download it now!
Bug 100298 - Style names come and go (are blanked out / white) in Styles and Formatting window (OSX ≤ 10.10)
Summary: Style names come and go (are blanked out / white) in Styles and Formatting wi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles Styles-Preview
  Show dependency treegraph
 
Reported: 2016-06-09 18:55 UTC by Harry
Modified: 2018-04-23 16:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Blanked style names illustrated in Styles and Formatting window. (163.22 KB, image/png)
2016-06-09 18:55 UTC, Harry
Details
Screenshot showing correct display of Header style list in sidebar (23.20 KB, image/png)
2016-09-16 09:46 UTC, Alex Thurgood
Details
Screenshot showing correct and incorrect Heading 1 display (118.83 KB, image/png)
2016-09-16 16:34 UTC, bug.reporter.21
Details
Short document that illustrates the bug on my Mac OS 10.9.5. (8.71 KB, application/vnd.oasis.opendocument.text)
2016-09-30 18:28 UTC, Harry
Details
Image of defect showing document in previous attachment, defects highlighted. (219.00 KB, image/png)
2016-09-30 18:32 UTC, Harry
Details
screencast of disappearing header (3.28 MB, video/quicktime)
2016-10-06 16:39 UTC, Alex Thurgood
Details
Active element in Styles and Formatting invisible (91.51 KB, image/png)
2016-11-07 09:03 UTC, Daniel T.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harry 2016-06-09 18:55:04 UTC
Created attachment 125579 [details]
Blanked style names illustrated in Styles and Formatting window.

On my Mac OS 10.9.5 laptop, with LibreOffice 4.x - 5.1.3 Writer, the Heading1 through Heading3 style are blank (all white).  They show OK on the Formatting dropdown tool.

Also some other styles are blank as well in this display.

I noticed that the style names come and go as I change the width of the windows.

I'm attaching an image file showing this.
Comment 1 Buovjaga 2016-06-12 14:28:05 UTC
I don't see the problem.

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Mac OS X 10.11.5; UI Render: default; 
Locale: en-US (en.UTF-8)
Comment 2 Alex Thurgood 2016-06-13 12:47:52 UTC
No repro with 

LO 5132
OSX 10.11.5
Comment 3 Alex Thurgood 2016-06-15 07:35:24 UTC
@Harry : pleae provide further details :

Macbook Pro, Macbook, Macbook Air, Retina screen or not ?

How wide is the Styles pane when the Styles disappear ?

Do you have the Styles pane and the Sidebar displayed at the same time, or do you use the More Styles entry in the Sidebar to display the complete list of styles ?

Setting needinfo
Comment 4 bug.reporter.21 2016-09-15 14:05:21 UTC
LO5152
OS X 10.10.5
MacBook Pro mid 2010 (no retina)
1) my default fonts are DejaVu
2) open a new empty writer document
3) Make the Style and Formatting sidebar deck visible from the sidebar settings.
4) Increase the width to the maximum : at some point, the "Heading 1" name is simply replaced by a dash character.

Document window width at its maximum.
No pane, only the document window.

In some more complicated situations, both "Heading 1" and "Heading 2" are replace by a dash.

Once you find where this dash comes from, you merely have solved the bug ;-)
Comment 5 Alex Thurgood 2016-09-16 09:43:21 UTC
No repro with 

Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 2; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: en-GB (fr.UTF-8)

Mac mini Server (mi-2010)
NVIDIA GeForce 320M 256 Mo
Moniteur : CHHWJT 30,5-pouce (1920 x 1080)
Comment 6 Alex Thurgood 2016-09-16 09:46:38 UTC
Created attachment 127359 [details]
Screenshot showing correct display of Header style list in sidebar
Comment 7 bug.reporter.21 2016-09-16 16:34:24 UTC
Created attachment 127371 [details]
Screenshot showing correct and incorrect Heading 1 display

What I primaryly thought was a dash seems to be the style name displayed at a very small font size.
Comment 8 Yousuf Philips (jay) (retired) 2016-09-29 01:20:17 UTC
Seems related to bug 92380.

Would be useful for those who are experience this to attach a document which shows this behaviour, even if it is empty, or do a screencast to further shed light on the issue.
Comment 9 Alex Thurgood 2016-09-30 07:14:29 UTC
(In reply to Yousuf Philips (jay) from comment #8)
> Seems related to bug 92380.
> 
> Would be useful for those who are experience this to attach a document which
> shows this behaviour, even if it is empty, or do a screencast to further
> shed light on the issue.

I might even go so far as to wager that this is a DUP of that bug, at least from Stuart's comments in bug92380#c29
Comment 10 Alex Thurgood 2016-09-30 07:16:06 UTC
@Harry : what are the font sizes of the affected styles when you see the problem on OSX 10.9.5 ?
Comment 11 Alex Thurgood 2016-09-30 07:26:54 UTC
And as Jay has indicated, could you provide us with a screencast showing the problem ? Thanks.
Comment 12 Harry 2016-09-30 18:28:01 UTC
Created attachment 127748 [details]
Short document that illustrates the bug on my Mac OS 10.9.5.

Image follows as another attachment.  Note that style names are too tiny; not invisible.
Comment 13 Harry 2016-09-30 18:32:47 UTC
Created attachment 127749 [details]
Image of defect showing document in previous attachment, defects highlighted.

Note that style names appear to be displayed in very tiny (single pixel high) font!
Comment 14 Harry 2016-09-30 19:03:41 UTC
I just added 2 attachments, a short .ODT document, 
    "Short document that illustrates the bug on my Mac OS 10.9.5.",
and a screenshot of it displaying the style name defects,
    "Image of defect showing document in previous attachment, defects highlighted.".

The weird behavior is that the Style name, "Title", disappeared as soon as I selected the title text and selected that style for it.  

The other 2 style names disappeared only after I manipulated the widths of the full document window and the Styles and Formatting pane.  When I readjusted the document window, the 2 other style names reappeared.  I noted that readjusting the Styles and Formatting pane width did not bring back the style names; only adjusting the full document window did that. 

I could not get the Title style name to reappear.  

Perhaps 2 different bugs are at work here? 

The font size of Title is 28.  The font size of the other 2 affected styles shown are,
    "Subtitle":  18
    "Table Index Heading": 16 

Another style also affected, but not shown in the captured image is
    "Heading 1":  18.2
.

This is on a Macbook Air, 13 inch, late 2010, with Intel Core 2 Duo, NVIDIA GeForce 320M 256 MB.
Comment 15 Harry 2016-09-30 19:07:00 UTC
It appears that styles were added from the many Word documents I have viewed and edited with this program.  Could this have corrupted my style data file?  I would be happy to post it if someone is interested and can tell me where it is stored.
Comment 16 Yousuf Philips (jay) (retired) 2016-10-04 04:46:25 UTC
From Harry's description of the bug, this seems to be not related to bug 92380 and didnt have any issues opening attachment 127748 [details].

@Harry: Can you provide a screencast using Jing (Mac) or screencast-o-matic.com, so we can observe this behaviour?
Comment 17 Harry 2016-10-04 16:32:42 UTC
As requested by Jay, I've uploaded a screencast of the bug's appearance at 

http://screencast.com/t/ekvbecMGyaV7
Comment 18 Alex Thurgood 2016-10-06 16:35:34 UTC
I managed to confirm this on an old Mac OSX 10.9.5 Macbook Pro that I laid my hands on.

I used LO 5142 and used Quicktime to record a screencast.
Comment 19 Alex Thurgood 2016-10-06 16:39:10 UTC
Created attachment 127842 [details]
screencast of disappearing header
Comment 20 Alex Thurgood 2016-10-06 16:49:48 UTC
I would add that in all probability this bug is unlikely to be fixed (unless by accident) because :

1) it only affects MacOSX
2) it only appears to affect versions of OSX 10.10 and older.
Comment 21 Harry 2016-10-07 00:46:50 UTC
Alex, thanks for making the effort to reproduce this bug. 

At least I now know it is not some unique corruption of my system.

I understand the reluctance to fix the bug as it only effects older Mac OS's, and it is more of a program usability annoyance than a critical show-stopper.
Comment 22 Daniel T. 2016-11-07 09:03:25 UTC
Created attachment 128541 [details]
Active element in Styles and Formatting invisible

I am able to reproduce this bug on my 
Kubuntu 16.04.1
LibreOffice Version: 5.1.4.2 
Build ID: 1:5.1.4-0ubuntu1
See attached screenshot.
Comment 23 Yousuf Philips (jay) (retired) 2016-11-07 14:25:57 UTC
The KDE issue is being handled in bug 98253.
Comment 24 QA Administrators 2018-04-22 02:32:07 UTC Comment hidden (obsolete)
Comment 25 Harry 2018-04-23 16:12:45 UTC
I no longer see this issue on my old Macbook Air. Thanks.
Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 2; OS: Mac OS X 10.9.5; UI render: GL; 
Locale: en-US (en.UTF-8); Calc: group