Download it now!
Bug 100308 - EDITING, UNDO, TABLE
Summary: EDITING, UNDO, TABLE
Status: RESOLVED DUPLICATE of bug 85909
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2016-06-10 12:18 UTC by jc.furest
Modified: 2016-06-14 07:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jc.furest 2016-06-10 12:18:58 UTC
Hello,
There is no undo in table formatting.
Steps to reproduce it:
create a new document
Add a new table, say 5x5 cells
Add text to the cells
Modify the format in any cell
run the undo command.
Only the added text will be undone.

Regards
Comment 1 raal 2016-06-10 14:55:13 UTC
I can not confirm with Version: 5.3.0.0.alpha0+
Build ID: 86d84ae4bba0d4c45bc13232645318291a8aed75
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-05-26_14:33:24
and Version: 5.3.0.0.alpha0+
Build ID: 2712fc0869e5ba3b7a1da41e0ce72431d3b0deee
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-06-02_22:41:55

Seems to be fixed in dev version. Please could you test with dev version?
http://dev-builds.libreoffice.org/daily/master/
Thank you
Comment 2 Cor Nouws 2016-06-10 18:37:27 UTC
> Seems to be fixed in dev version.

See here 
  http://vmiklos.hu/blog/sd-undo-fixes.html
and related :)
Comment 3 jc.furest 2016-06-13 07:10:02 UTC
I can reproduce this issue with the 5.3.0.0.
The Undoi works in Write, but not in Draw. Didn't check if the undo is effective in Impress.
Will try to completely uninstall my stable version and reboot.
Comment 4 jc.furest 2016-06-13 07:57:35 UTC
The behaviour is still there, tried in impress and draw. Write works beautifully.
Even worse: if a cell formatting is applied, the table is not redrawn until some text is entered in any cell.
the http://vmiklos.hu/blog/sd-undo-fixes.html seems no more to be implemented.
Is this a regression?
regards
Comment 5 jc.furest 2016-06-13 11:11:00 UTC
Sorry, this must help:
Version: 5.3.0.0.alpha0+
Build ID: 2ad5055145201efe5a244656a0715b391149e825
CPU Threads: 8; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-29_22:57:40
Locale: de-CH (de_CH)
Comment 6 Buovjaga 2016-06-13 11:49:11 UTC
No problem undoing Draw table cell formatting - text does not get deleted.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+ (x64)
Build ID: f536a83d51443d19dba58157cea28fb67a090e02
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-06-13_01:19:21
Locale: fi-FI (fi_FI)
Comment 7 Buovjaga 2016-06-13 11:50:54 UTC
Maybe give us a specific description of what formatting you are changing and how (character, paragraph or cell).
Comment 8 jc.furest 2016-06-13 12:53:18 UTC
Hello, 
You will find a small video showing the formatting matter.
https://drive.google.com/open?id=0B7DwxkAzR4hsb1MyZHp2REYyOE0
There is no Undo when applying frame color or width change in the cell.
And the cell is not redrawn after the change, only if some text is added/modified in the table.
Do I need to reopen a Bug to the second issue?
Regards
Comment 9 Heiko Tietze 2016-06-14 07:51:27 UTC
Thanks for the screencast. Copied the link to the other bug.

*** This bug has been marked as a duplicate of bug 85909 ***