Bug 100347 - FILESAVE FILEOPEN after exporting to xlsx format grouping are lost for columns
Summary: FILESAVE FILEOPEN after exporting to xlsx format grouping are lost for columns
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:5.3.0 target:5.2.5
Keywords:
: 57502 64613 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-12 21:42 UTC by Bartosz
Modified: 2016-12-05 17:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with Grouped Rows and Columns (8.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-06-12 21:42 UTC, Bartosz
Details
Screenshot after fix of xlsx exporting (29.11 KB, image/png)
2016-06-12 22:24 UTC, Bartosz
Details
Screenshot Libreoffice before outline fix (35.67 KB, image/png)
2016-06-12 22:26 UTC, Bartosz
Details
Empty outline created by Excel 2010 (8.42 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-06-23 15:42 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz 2016-06-12 21:42:37 UTC
Created attachment 125622 [details]
Document with Grouped Rows and Columns

After exporting to xlsx format, Libreoffice is not preserving grouping and outlining for columns.
Also reading is not working correctly.

Steps to reproduce.
1. Open attached ods file
2. Notice that Rows and Columns are grouped and outlined
3. Export to xlsx
4. Open exported file

Currently:
- Only Outlines for rows are accessible

Expected:
-  Outlines for rows and columns are accessible
Comment 1 Bartosz 2016-06-12 22:20:30 UTC
Review is available at:
https://gerrit.libreoffice.org/#/c/26201/
Comment 2 Bartosz 2016-06-12 22:24:48 UTC
Created attachment 125624 [details]
Screenshot after fix of xlsx exporting
Comment 3 Bartosz 2016-06-12 22:26:05 UTC
Created attachment 125625 [details]
Screenshot Libreoffice before outline fix
Comment 4 Bartosz 2016-06-17 14:54:26 UTC
New review with post review fixes, is available at:
https://gerrit.libreoffice.org/#/c/26340/
Comment 5 Bartosz 2016-06-19 15:33:19 UTC
*** Bug 64613 has been marked as a duplicate of this bug. ***
Comment 6 Bartosz 2016-06-23 15:42:04 UTC
Created attachment 125863 [details]
Empty outline created by Excel 2010
Comment 7 Bartosz 2016-06-28 09:17:36 UTC

*** This bug has been marked as a duplicate of bug 93045 ***
Comment 8 Bartosz 2016-07-03 21:13:30 UTC
*** Bug 57502 has been marked as a duplicate of this bug. ***
Comment 9 Bartosz 2016-07-03 21:17:05 UTC
I made a mistake by closing this bug too early
Comment 10 Bartosz 2016-07-03 21:17:57 UTC
The latest review is available at:
https://gerrit.libreoffice.org/#/c/26625/
Comment 11 Commit Notification 2016-07-04 00:02:54 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc503abb860c33a54a188640a5962dbdf7052284

tdf#100347 Fix Outline export into XLSX format

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2016-12-05 17:44:58 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21d340948d564c819e24edd96051c42a9ca2c78e&h=libreoffice-5-2

tdf#100347 Fix Outline export into XLSX format

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.