Bug 100348 - PPT(X) export of fontwork does not work
Summary: PPT(X) export of fontwork does not work
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:7.1.0
Keywords: filter:pptx
: 125024 (view as bug list)
Depends on: 125573
Blocks: FontWork-WordArt PPTX
  Show dependency treegraph
 
Reported: 2016-06-13 08:37 UTC by mail
Modified: 2020-07-10 15:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with fontwork, cannot be exported to ppt / pptx (789.00 KB, application/vnd.oasis.opendocument.presentation)
2016-06-13 08:37 UTC, mail
Details
Screenshot of Powerpoint rendering LO's pptx export (895.75 KB, image/png)
2016-06-13 08:38 UTC, mail
Details
PPTX result from LO 6.2 a0 (2.39 MB, image/png)
2018-10-22 07:41 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2016-06-13 08:37:19 UTC
Created attachment 125630 [details]
Presentation with fontwork, cannot be exported to ppt / pptx

Exporting the attached one-slide presentation with fontwork text to ppt / pptx format does not work: 

ppt: The resulting file cannot be opened with Powerpoint 2010. LO opens it flawlessly

pptx: The resulting file opens in both Powerpoint 2010 and LO with the fontwork gone. See attached png file
Comment 1 mail 2016-06-13 08:38:45 UTC
Created attachment 125631 [details]
Screenshot of Powerpoint rendering LO's pptx export
Comment 2 mail 2016-06-13 08:40:53 UTC
Strange, trying to open .ppt format a second time with Powerpoint 2010 worked.
Comment 3 Buovjaga 2016-06-14 14:35:38 UTC
Repro with pptx.

Win 8.1 32-bit
MSO2013
LibO Version: 5.3.0.0.alpha0+
Build ID: bb6acbd0c3e8240c976ed62e04275ec67fa5a61d
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-06-11_00:27:38
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2018-10-22 02:47:20 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-10-22 07:41:49 UTC
Created attachment 145893 [details]
PPTX result from LO 6.2 a0
Comment 6 Roman Kuznetsov 2018-10-22 07:42:11 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: cec31fdedd7c94f4ebf903a66456a75867db22b0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-21_22:54:44
Locale: ru-RU (ru_RU); Calc: threaded
Comment 7 raal 2019-05-21 17:19:24 UTC
*** Bug 125024 has been marked as a duplicate of this bug. ***
Comment 8 Regina Henschel 2019-06-09 16:04:59 UTC
Export to binary ppt works for me in Version: 6.4.0.0.alpha0+ (x64)
Build ID: 87238627b025ee6aa61378667e56b1769d4460c2
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-09_03:04:32
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

But export to pptx is still totally broken.
Comment 9 Commit Notification 2019-06-17 16:49:32 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2be2c914ed48823304c2e95a836ee93a08853628%5E%21

tdf#51195, tdf#100348 Convert Fontwork to TextWarp on export

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-06-20 15:03:17 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a4d30a3809c5bf973d39c5e4368a1276582b04b3%5E%21

tdf#100348 unittest Convert Fontwork to TextWarp on export

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Regina Henschel 2019-06-24 21:40:20 UTC
The missing scaling of the text is in bug 125573. Patch is in https://gerrit.libreoffice.org/74644
Comment 12 Regina Henschel 2019-06-29 22:07:57 UTC
The fontwork object in the attached presentation has an additional adjustment value, which should not be there. How was this special fontwork object created?

Because of this additional value, the pptx-file has two adjustment values and PowerPoint will show no text at all.
Comment 13 mail 2019-09-30 08:44:49 UTC
I'm sorry, it's more than three years ago when I created the slide - I can't remember and I'm not using LO anymore for new content.
Comment 14 Commit Notification 2020-07-09 22:57:43 UTC
Regina Henschel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/005f5db47b8e1bbd7ebddee92009be072e835fd5

tdf#100348 add fill to fontwork in export to pptx

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Regina Henschel 2020-07-10 15:15:06 UTC
Export to pptx is fixed now. Export to docx is covered by bug 51195.

Import is a different problem and should be tracked in a separate bug report.