Download it now!
Bug 100365 - LibreOffice close when try to create a chart
Summary: LibreOffice close when try to create a chart
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2016-06-14 04:03 UTC by alfonso
Modified: 2017-01-26 03:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
gdbtrace.log (14.22 KB, text/x-log)
2016-06-14 20:37 UTC, alfonso
Details
trace libreoffice (28.30 KB, text/x-log)
2016-06-14 21:40 UTC, alfonso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alfonso 2016-06-14 04:03:15 UTC
LibreOffice close when try to do a chart. After that recovery document open.
Comment 1 Julien Nabet 2016-06-14 19:04:14 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux)?

If you can still reproduce this, could you retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 2 alfonso 2016-06-14 19:38:04 UTC
GNU gdb (Debian 7.7.1+dfsg-5) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
log will be saved as gdbtrace.log, this will take some time, patience...

(soffice:21935): Gdk-WARNING **: gdk_window_set_icon_list: icons too large

(soffice:21935): Gdk-WARNING **: gdk_window_set_icon_list: icons too large
Gen6+ requires Kernel 3.6 or later.
soffice.bin: ../../../../src/mesa/main/context.c:1541: handle_first_current: Assertion `ctx->Version > 0' failed.
Comment 3 Julien Nabet 2016-06-14 20:21:16 UTC
Could you attach gdbtrace.log by using this link https://bugs.documentfoundation.org/attachment.cgi?bugid=100365&action=enter ?
Comment 4 alfonso 2016-06-14 20:37:06 UTC
Created attachment 125653 [details]
gdbtrace.log

Bug when try to create a Chart
Comment 5 Julien Nabet 2016-06-14 21:06:20 UTC
Could you try this:
- Menu Tools/Options/View:
uncheck Use hardware acceleration.
?

If you still reproduce this, uncheck too "Use anti-aliasing".
Comment 6 alfonso 2016-06-14 21:40:39 UTC
Created attachment 125655 [details]
trace libreoffice

After uncheck both options "Use hardware acceleration" and "Use anti-aliasing" libreoffice still close unexpectedly
Comment 7 Julien Nabet 2016-06-15 05:11:50 UTC
Thank you for your feedback, last thing to try:
Menu Tools/Options/OpenCL: uncheck both options (Allow Use of Soft interpreter, Allow use of OpenCL)
Like OpenGL test, I think you must restart LO to give a try.

After this, I must recognize I'm stuck.
Comment 8 alfonso 2016-06-16 12:43:08 UTC
After uncheck both options (Allow Use of Soft interpreter,
Allow use of OpenCL) no solution. Still LO close unexpectly.

As last resort, i will uninstall and install LO again.
Comment 9 alfonso 2016-06-16 14:09:17 UTC
I just remove LO and download last version LibreOffice_5.0.6.3_Linux_x86_deb. Then run LO again and try to make a chart. Result: Fail Again.
Comment 10 Julien Nabet 2016-06-16 19:07:42 UTC
Since I don't have more questions, I'll put it back to UNCONFIRMED.
Comment 11 Aron Budea 2016-06-17 04:16:07 UTC
I can't say I'm familiar with this, but if hardware acceleration is turned off in settings, why are there still GL calls in the second trace?
Comment 12 Buovjaga 2016-06-17 18:35:32 UTC
What is it that you are trying to create a chart from? Can you share the document?
Comment 13 alfonso 2016-06-20 13:40:41 UTC
(In reply to Buovjaga from comment #12)
> What is it that you are trying to create a chart from? Can you share the
> document?

I only have 2 rows, for examble:

row1    |   row2
-----------------
1           22
2           27
3           56
4           66
5           22

I made another test, if i clic on chart button, only doing that my LO close unexpected.
Comment 14 Rpnpif 2016-08-04 09:23:28 UTC
Comment on attachment 125655 [details]
trace libreoffice

Typo
Comment 15 Julien Nabet 2016-08-04 09:58:08 UTC
(In reply to Rpnpif from comment #14)
> Comment on attachment 125655 [details]
> trace libreoffice
> 
> Typo

Noticing OpenGL part in your bt, could you disable OpenGL (in Menu Tools/Options) and give a new try for the test?
Comment 16 Aron Budea 2016-08-07 16:09:03 UTC
Please try with LibreOffice 5.1.5.2 or 5.2.0.4 (other reports indicate a very similar issue is fixed in 5.2.0.4).
Comment 17 Buovjaga 2016-08-07 16:19:27 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED DUPLICATE of bug 94209, if the problem went away.
Comment 18 Aron Budea 2017-01-26 03:05:10 UTC
No update, closing due to lack of information.
Let's hope an update fixed the crash.