Bug Hunting Session
Bug 100381 - REPORT BUILDER : XY chart in report - X values field setting not remembered
Summary: REPORT BUILDER : XY chart in report - X values field setting not remembered
Status: RESOLVED DUPLICATE of bug 68663
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-14 20:48 UTC by branestawm
Modified: 2016-06-16 12:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
2 tables each 5 records, 3 fields in embedded HSQLDB to show XY chart bug (43.26 KB, application/vnd.oasis.opendocument.database)
2016-06-14 20:48 UTC, branestawm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description branestawm 2016-06-14 20:48:08 UTC
Created attachment 125654 [details]
2 tables each 5 records, 3 fields in embedded HSQLDB to show XY chart bug

When configuring an XY chart in Base Report Builder, the x values field (dates) setting is not remembered. Consequently the x-axis values are wrong (they are set to the start of the epoch).

Example charttest.odb file attached (2 tables each 5 records, 3 fields in embedded HSQLDB). Report 'XY chart2' uses table 'Events2' as data source, with y values from field 0 and x-values (dates) from field 1, which are not used when the report is executed.

This does not seem to be quite the same bug as 91289 where x-values (dates) are reported to be missing (rather than wrong/incorrect). 
 
LibreOffice 5.1.3.2 on OpenSuse 13.2 x64.


[I'm a noobie to Base and to Bugzilla. I think I'm using Base charts correctly - no response on AskLO - and I hope this report is clear].
Comment 1 Alex Thurgood 2016-06-16 08:40:02 UTC
Confirming on

Version: 5.3.0.0.alpha0+
Build ID: 637371d4d90c2403f02d588ebe745368014b1032
CPU Threads: 2; OS Version: Mac OS X 10.11.5; UI Render: default; 
Locale: fr-FR (fr.UTF-8)
Comment 2 Alex Thurgood 2016-06-16 09:34:28 UTC
Methinks this is a result of the underlying effects of, and is also a DUP of, bug 68663
Comment 3 branestawm 2016-06-16 12:30:13 UTC
(In reply to Alex Thurgood from comment #2)
> Methinks this is a result of the underlying effects of, and is also a DUP
> of, bug 68663

I agree this bug duplicates 68633 (I didn't look back far enough).  Both are concerned with X values field setting in XY charts.
Comment 4 Alex Thurgood 2016-06-16 12:51:35 UTC

*** This bug has been marked as a duplicate of bug 68663 ***