Bug Hunting Session
Bug 100387 - PPTX export of user defined animation (simple bullet list) fails
Summary: PPTX export of user defined animation (simple bullet list) fails
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Paul Trojahn
URL:
Whiteboard: target:6.0.0
Keywords: filter:pptx
: 113054 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-15 07:42 UTC by mail
Modified: 2017-10-24 11:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The user defined animation (bullet list) no longer works when saved in pptx format. (64.94 KB, application/vnd.oasis.opendocument.presentation)
2016-06-15 07:42 UTC, mail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2016-06-15 07:42:26 UTC
Created attachment 125659 [details]
The user defined animation (bullet list) no longer works when saved in pptx format.

When exporting the attached presentation to PPTX format and opening it with Powerpoint 2010, all bullet points of the list on the second slide appear at once instead of one after the other. You still have to click several times before the presentation finishes.

Looking at the user defined animation parameters, there are still three animation steps but not the text entries that should appear.

When opening the pptx-file in LO, the faulty behaviour is the same.

This is one of the bugs described in #100349.
Comment 1 mail 2016-06-15 07:50:17 UTC
Saving in ppt format and opening with Powerpoint works flawlessly.

Tested with Powerpoint 2010.
Comment 2 Buovjaga 2016-06-15 11:23:47 UTC
I confirmed in the original bug 100349

Win 8.1 32-bit
MSO2013
LibO Version: 5.3.0.0.alpha0+
Build ID: bb6acbd0c3e8240c976ed62e04275ec67fa5a61d
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-06-11_00:27:38
Locale: fi-FI (fi_FI)
Comment 3 Commit Notification 2017-08-19 03:10:19 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=81d40428bbcfe332b78e154b4cd3fd7feff5ff73

tdf#100387 Fix OOXML export of animated lists

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-08-25 09:28:30 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69cfafef7a28aad7a013bb440e15e23e59ea628c

tdf#100387 tdf#100389 OOXML animation export fixes

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Aron Budea 2017-10-24 11:19:10 UTC
*** Bug 113054 has been marked as a duplicate of this bug. ***