Bug 100491 - FILEOPEN: Docx arrows not correctly rendered: too thick
Summary: FILEOPEN: Docx arrows not correctly rendered: too thick
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
QA Contact:
URL:
Whiteboard: interoperability target:6.0.0 target:...
Keywords: filter:docx, filter:pptx
: 48864 101531 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2016-06-20 06:19 UTC by Laurent Godard
Modified: 2017-10-09 00:00 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
the docx file (51.29 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-06-20 06:19 UTC, Laurent Godard
Details
libreoffice arrows rendered (see heads) (17.42 KB, image/png)
2016-06-20 06:20 UTC, Laurent Godard
Details
word rendered arrows (expected) (13.83 KB, image/png)
2016-06-20 06:21 UTC, Laurent Godard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2016-06-20 06:19:37 UTC
Created attachment 125745 [details]
the docx file

The arrow heads are not correctly rendered (approximative)
Comment 1 Laurent Godard 2016-06-20 06:20:31 UTC
Created attachment 125746 [details]
libreoffice arrows rendered (see heads)
Comment 2 Laurent Godard 2016-06-20 06:21:14 UTC
Created attachment 125747 [details]
word rendered arrows (expected)
Comment 3 Buovjaga 2016-06-25 19:02:15 UTC
Confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: c13f60e7cd18df6b0ab70289f5b91ee01e4ae126
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 18th 2016
Comment 4 Aron Budea 2016-07-05 03:50:09 UTC
Probably inherited from OOo, but the first version I could see any arrows in the document was 3.6.0.4. Also looks closely related to bug 82760.
Comment 5 Aron Budea 2016-08-15 19:28:02 UTC
*** Bug 101531 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2016-08-15 19:30:24 UTC
https://bugs.documentfoundation.org/attachment.cgi?id=126834
Attachment from bug 101531 shows the same issue with pptx.
Comment 7 Armin Le Grand (CIB) 2016-10-06 08:44:16 UTC
Arrows have an attribute percentage of position on line relative to arrow width that controls how far the line gets shortened. Usually this is 50% making the arrow to be connected at it's center. I think this could be used to get the import right, but would need some investigation. Looks as if MS does not have that.
Comment 8 Xisco Faulí 2017-07-23 10:41:25 UTC
Gerrit patch: https://gerrit.libreoffice.org/#/c/40286/
Comment 9 Xisco Faulí 2017-07-23 10:41:45 UTC
*** Bug 48864 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2017-07-26 06:15:53 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d3b7a07c02c90d2d64a630ab84886ef3096edfc

tdf#100491 fix DOCX import shape line with arrow marker

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-07-26 12:45:29 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=235f16a7c50de9908ce32fd6f1347c7b888bc1b7&h=libreoffice-5-4

tdf#100491 fix DOCX import shape line with arrow marker

It will be available in 5.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Cor Nouws 2017-08-17 07:50:18 UTC
Reading from the commit message:
" Line shape with arrow end markers was rendering rather thick arrow, not connected to main line. Moreover, arrow width should depend on actual line width. "
I verify this has been fixed. Thanks Vasily!

(there are little problems with the position of some of the arrows - but that's a different issue.)
Comment 13 Cor Nouws 2017-08-17 07:51:16 UTC
ok in Version: 6.0.0.0.alpha0+
Build ID: 75933b220d48bceff25b07cfc4b55c70a2e24917
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-16_22:50:24
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 14 Commit Notification 2017-10-09 00:00:20 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91d5cebbde2e854a73a9a7633725350df1418387

tdf#100491: Reduce DOCX shapes arrow line ending size multiplier

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.