Download it now!
Bug 100549 - Reorganizing “Borders” group button on “Formatting Toolbar”
Summary: Reorganizing “Borders” group button on “Formatting Toolbar”
Status: RESOLVED DUPLICATE of bug 58349
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Cell-Border Split-Group-Buttons Calc-Toolbars
  Show dependency treegraph
 
Reported: 2016-06-22 14:49 UTC by hakan
Modified: 2020-07-28 23:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Image-1 (84.22 KB, image/png)
2016-06-22 14:49 UTC, hakan
Details
Image-2 (70.33 KB, image/png)
2016-06-22 14:49 UTC, hakan
Details
Image-3 (54.01 KB, image/png)
2016-06-23 11:33 UTC, hakan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hakan 2016-06-22 14:49:02 UTC
Created attachment 125836 [details]
Image-1

P.S. My English is not excellent, sorry for that. Attached images can explain my suggestion better. In a nutshell, between the attached images, I’d prefer to use (C) or (D), rather than use (A) or (B).

At the Image-1, buttons in the menu which I marked with (A) are too small and useless. Also there are some mismatches between (A) and (B) menus.

1. Square shaped buttons located in menu (A), are 2 px smaller than the buttons in menu (B).

2. The view of the icons is different. Icons located in menu (A) have border around them.  But icons in menu (B) don’t have border around them. Icons have a clearer view without border.

3. Placement the icons is different, too.

4. There are different border options. For example, there are diagonal borders in menu (B), but there aren't in menu (A).

Because of all these reasons, I suggest to readjust the menus with same form at Image-2 for being compatible with one another and presenting a useful content. Option (D) of Image-2 is connected with the result of ID: 100548 bug record. If number 100548 bug record is accepted, all border options can be done compatible with eachother by using option (D).
Comment 1 hakan 2016-06-22 14:49:26 UTC
Created attachment 125837 [details]
Image-2
Comment 2 V Stuart Foote 2016-06-22 18:40:54 UTC
OK, also seems reasonable. But same question as in bug 100548 about "loss" of the existing preset border selections while making them larger. 

I think it would be reasonable moving it this direction, but not sure if we could even use the multi-line picker of mockup (D) in the toolbar .UI GTK button box -- Samuel, Tomaž?

Otherwise we should attempt to make the layout of the Cell border settings on each of the--Toolbar, the Format Cell dialog, the Sidebar  Properties deck Cell Appearance panel--consistent.
Comment 3 Heiko Tietze 2016-06-22 19:36:13 UTC
From the HIG [1]: "Prefer controls where the setting is one click away...", "Consider introducing presets of properties comprising of the most relevant settings."

So I would make it even simpler with no floating widget containing all border settings but the most relevant three (none, outline, grid). And of course easy access to the dialog.

[1] https://wiki.documentfoundation.org/Design/SideBar
Comment 4 hakan 2016-06-23 11:33:45 UTC
Created attachment 125855 [details]
Image-3

Ya da Image-3'deki gibi olabilir. Bu menünün bir şekilde iyileştirilmesi lazım.
Comment 5 hakan 2016-06-23 11:35:09 UTC
(Excuse me, I forgot English translations)
Or it may be as Image-3 wherein. This menu is somehow need to be improved.
Comment 6 V Stuart Foote 2016-06-23 21:02:26 UTC
(In reply to Heiko Tietze from comment #3)
> From the HIG [1]: "Prefer controls where the setting is one click away...",
> "Consider introducing presets of properties comprising of the most relevant
> settings."
> 
> So I would make it even simpler with no floating widget containing all
> border settings but the most relevant three (none, outline, grid). And of
> course easy access to the dialog.
> 
> [1] https://wiki.documentfoundation.org/Design/SideBar

Well the other way to go would be to make it a split button and stateful to remember the last applied style on button click or drop the picker.

As in bug 58349 - Turn Border button into a split button.
Comment 7 Heiko Tietze 2020-07-27 14:28:48 UTC
(In reply to V Stuart Foote from comment #6)
> Well the other way to go would be to make it a split button...

Let's do this.

*** This bug has been marked as a duplicate of bug 58349 ***