Bug 100595 - MacOs strange logs on startup with brand new profile
Summary: MacOs strange logs on startup with brand new profile
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2016-06-24 17:54 UTC by Julien Nabet
Modified: 2018-06-12 05:16 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2016-06-24 17:54:29 UTC
On MacOS 10.11.5 with master sources updated some days ago, I got this on console when launching LO Writer or Calc for example with brand new LO profile:
warn:sal.osl.pipe:5855:1:sal/osl/unx/pipe.cxx:395: shutdown() failed: Socket is not connected
warn:sal.osl.pipe:5855:3:sal/osl/unx/pipe.cxx:436: accept() failed: Software caused connection abort
warn:sal.osl:5855:8:sal/osl/unx/socket.cxx:932: undefined address

Steps to reproduce (with brand new profile)
Just launch Writer from console

These don't appear on console when profile directory exists
Perhaps it's nothing but perhaps it hides something more serious.
Comment 1 Alex Thurgood 2016-06-27 10:15:58 UTC
@Julien : might it be the crash reporter trying to instantiate itself ?
Comment 2 Alex Thurgood 2016-06-27 10:16:26 UTC
I remember seeing this once, so confirming.
Comment 3 QA Administrators 2018-06-12 02:33:38 UTC Comment hidden (obsolete)
Comment 4 Julien Nabet 2018-06-12 05:16:41 UTC
Since I don't have a Mac anymore, I can't tell.
Let's put this one as WFM then.