Bug 100610 - FILEOPEN PPTX Placement of data labels in pie and bar charts is a bit off
Summary: FILEOPEN PPTX Placement of data labels in pie and bar charts is a bit off
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: OOXML-Chart PPTX
  Show dependency treegraph
 
Reported: 2016-06-26 00:53 UTC by Carlos
Modified: 2019-06-13 11:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The error in the graphic - name (726.47 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-06-26 00:53 UTC, Carlos
Details
PDF from MSO 2013 (723.66 KB, application/pdf)
2016-07-10 19:08 UTC, Buovjaga
Details
comparison MSO 2010 and LibreOffice 6.3 Master (97.08 KB, image/png)
2019-01-04 00:11 UTC, Xisco Faulí
Details
Minimized example document saved by PP 2013 (32.53 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-01-21 13:04 UTC, Gabor Kelemen
Details
Screenshot of the minimized example in PP and LO 6.3 (81.30 KB, image/png)
2019-01-21 13:06 UTC, Gabor Kelemen
Details
Screenshot of the minimized example in PP and LO 6.4 (86.52 KB, image/png)
2019-06-13 11:56 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos 2016-06-26 00:53:18 UTC
Created attachment 125905 [details]
The error in the graphic - name

Na hora de importar uma apresentação com graficos do microsoft office, as descrições dos graficos ficam desconfiguradas. No meu caso ficaram muito para baixo.
Comment 1 Buovjaga 2016-07-10 19:08:01 UTC
Created attachment 126153 [details]
PDF from MSO 2013

Difference to LibO:
- pie charts have grey background
- the placement of numbers in pie and bar charts is a bit off in LibO

Win 8.1 32-bit
MSO 2013
LibO Version: 5.3.0.0.alpha0+
Build ID: f5af917e3b91037002419ba33c6921a74ca7d4e1
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-10_09:00:08
Locale: fi-FI (fi_FI); Calc: group
Comment 2 QA Administrators 2017-09-01 11:18:28 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2019-01-04 00:11:36 UTC
Created attachment 147984 [details]
comparison MSO 2010 and LibreOffice 6.3 Master
Comment 4 Gabor Kelemen 2019-01-21 13:04:24 UTC
Created attachment 148475 [details]
Minimized example document saved by PP 2013
Comment 5 Gabor Kelemen 2019-01-21 13:06:05 UTC
Created attachment 148476 [details]
Screenshot of the minimized example in PP and LO 6.3

One of the problems is that the legend of the 3D bar chart follows the top-to-bottom order as left-to-right in PP, while it is reversed in Impress.

Version: 6.3.0.0.alpha0+
Build ID: cec7ae9f3c69ecc83462f28fc4987e37dc1b420e
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc:
Comment 6 Gabor Kelemen 2019-01-21 13:10:17 UTC
About the grey background: it disappears because in LO there is no separate background property for the Chart itself, only for the whole Chart Area (that is including the title and legend boxes).

Maybe we could interopgrabbag that property?
Comment 7 Gabor Kelemen 2019-06-13 11:56:06 UTC
Created attachment 152167 [details]
Screenshot of the minimized example in PP and LO 6.4

The order of the legend items is now corrected and matches that of PP.
Comment 8 Gabor Kelemen 2019-06-13 11:58:33 UTC
Let's keep this around for the chart background color.