Bug Hunting Session
Bug 100671 - DOCX: chapter numbers imported as text, not as references in numbering captions
Summary: DOCX: chapter numbers imported as text, not as references in numbering captions
Status: RESOLVED DUPLICATE of bug 42346
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-29 10:09 UTC by Andrey Skvortsov
Modified: 2016-08-05 22:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test document created in Word 2010 (123.59 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-06-29 10:09 UTC, Andrey Skvortsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Skvortsov 2016-06-29 10:09:51 UTC
Created attachment 125974 [details]
test document created in Word 2010

Steps to reproduce the issue:
* open in LO attached document
  Document looks good, caption numbering looks correct (Figure 1.1, Table 2.1), but...

* Press Ctrl-F9 to show field codes.
  Look at chapter numbers in captions (Figure 1 [Number range Figure], Table 2 [Number range Table]). Chapter numbers are imported just as numbers.

* Add another chapter before Chapter 1.
  See that chapter numbers in captions are still the same, but should be changed to Figure 2.1 and Table 3.1.
 

The attached document was tested with LO 5.1.4.2. 


I see that numbering style is not imported, maybe this is root of the problem.
Steps to check this:
* add another caption to the image in document. 
* select category 'Figure'
* click 'Options...'
* see that 'Numbering Captions by Chapter'-'Level' is set to 'None'.

You can set level to 1 and see how captions and references to figures'll get correct numbers.
Comment 1 Gert Van Waelvelde 2016-06-29 22:36:34 UTC
I can reproduce this in LO 5.2.0.1.0
Comment 2 Cor Nouws 2016-08-05 22:00:22 UTC
Hi Andrey,

I think this is the same as bug 42346
Please reopen (with explanation) if you do not agree, Thanks!

*** This bug has been marked as a duplicate of bug 42346 ***
Comment 3 Cor Nouws 2016-08-05 22:01:09 UTC
(maybe not a dup, but related - i.e. behavior the other way round)