Download it now!
Bug 100675 - FILEOPEN Header image hides a bit of the text
Summary: FILEOPEN Header image hides a bit of the text
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:doc
Depends on:
Blocks: DOC-Images DOC-Header-Footer
  Show dependency treegraph
 
Reported: 2016-06-29 13:44 UTC by E.Mi
Modified: 2020-04-16 07:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
doc1 (137.00 KB, application/msword)
2016-06-29 13:44 UTC, E.Mi
Details
screenshot (240.50 KB, image/jpeg)
2016-06-29 14:33 UTC, E.Mi
Details
MS Word (39.90 KB, image/png)
2016-08-09 08:00 UTC, E.Mi
Details
Microsoft Word2003 - reuniao_3_jubilados.pdf: picture is before text, not behind. (119.59 KB, application/pdf)
2020-04-16 07:17 UTC, Justin L
Details
Microsoft Word2016 - reuniao_3_jubilados.pdf: picture is before text, not behind. (498.98 KB, application/pdf)
2020-04-16 07:19 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E.Mi 2016-06-29 13:44:49 UTC
Created attachment 125979 [details]
doc1
Comment 1 Cor Nouws 2016-06-29 14:23:17 UTC
Hi ekari,

thanks for filing the issue.
I do not see a problem when I open the file in 5.1.4.2 or 5.2.0.1

Can you pls attach a screen shot of what is wrong?
Ciao - Cor
Comment 2 E.Mi 2016-06-29 14:33:29 UTC
Created attachment 125985 [details]
screenshot

Outlined in red
Comment 3 E.Mi 2016-06-29 15:06:48 UTC
Changing to unconfirmed
Comment 4 Cor Nouws 2016-06-29 18:11:11 UTC
Ah yes, thanks, It's not that much, but..
Comment 5 Gert Van Waelvelde 2016-06-29 23:23:22 UTC
Simply resizing the image fixes the problem, so this may not be a bug but sloppy formatting from the user who created the document.

Could anyone perhaps check whether this issue occurs in MS Word as well? If the document renders perfectly in Word, it is a bug.
If the same issue occurs in Word, it's sloppy formatting and not a bug.
Comment 6 E.Mi 2016-06-30 00:18:20 UTC
I don't have MS word to test
Comment 7 Aron Budea 2016-08-09 02:39:13 UTC
Let's return this to UNCONFIRMED until someone can confirm how it looks in Word.

What I can confirm is that it looks the same in LibreOffice 3.3.0 / Windows 7, so it's not a regression.
Comment 8 E.Mi 2016-08-09 08:00:57 UTC
Created attachment 126684 [details]
MS Word
Comment 9 Xisco Faulí 2016-09-08 14:35:28 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2018-10-06 02:49:54 UTC Comment hidden (obsolete, spam)
Comment 11 Justin L 2020-04-16 07:17:21 UTC
Created attachment 159610 [details]
Microsoft Word2003 - reuniao_3_jubilados.pdf: picture is before text, not behind.

LO shows it the same as Word 2003 does. Not a bug.
Comment 12 Justin L 2020-04-16 07:19:59 UTC
Created attachment 159611 [details]
Microsoft Word2016 - reuniao_3_jubilados.pdf: picture is before text, not behind.

Word 2016 also has the text partially hidden. Note that comment 8 used Word Viewer, not an actual version of Word.
Comment 13 Justin L 2020-04-16 07:23:52 UTC
wr (4 bits): An unsigned integer that specifies the style of text wrapping around this shape. This MUST be one of the following values.
...
2 Wrap text around an absolutely positioned object (square wrapping).
3 Display as if the shape is not there. The shape appears either in front of or behind the text, based on fBelowText.

C - fBelowText (1 bit): An unsigned integer that specifies whether this shape is behind the text. A value of 1 specifies that the shape appears behind the paragraph. A value of 0 specifies that the shape appears in front of the text and obscures it. If wr is not 3, this field MUST be ignored.

In this document, wr==2, so fBelowText must be ignored.  [bBelowText in sw]