Bug 100680 - FILEOPEN DOCX Image anchored as character + long word wrapped differently
Summary: FILEOPEN DOCX Image anchored as character + long word wrapped differently
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: interoperability target:7.4.0
Keywords: filter:docx
Depends on:
Blocks: DOCX-Header-Footer DOCX-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2016-06-29 14:17 UTC by E.Mi
Modified: 2022-04-29 07:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
docx1 (62.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-06-29 14:17 UTC, E.Mi
Details
Screenshot of supposed bug (12.10 KB, image/png)
2016-06-29 22:49 UTC, Gert Van Waelvelde
Details
Screenshot of the original document side by side in Word and Writer (120.63 KB, image/png)
2021-02-03 11:43 UTC, NISZ LibreOffice Team
Details
Minimized example file (45.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-02-03 11:45 UTC, NISZ LibreOffice Team
Details
Screenshot of the minimized example side by side in Word and Writer (126.59 KB, image/png)
2021-02-03 11:45 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description E.Mi 2016-06-29 14:17:58 UTC
Created attachment 125984 [details]
docx1
Comment 1 Gert Van Waelvelde 2016-06-29 22:49:03 UTC
Created attachment 125995 [details]
Screenshot of supposed bug
Comment 2 Gert Van Waelvelde 2016-06-29 22:57:36 UTC
When I open this document, the part of the line just underneath the logo in the header appears lower than the rest of the line (see my screenshot).

Is this the malformation you mean? 
It is important to describe these things in great detail in your bug reports.
Always describe the exact problem, as well as what you think it is supposed to look like.
Otherwise it may not be clear what the exact bug is.

Thanks.
Comment 3 E.Mi 2016-06-30 00:16:27 UTC
Yes that's the bug, thanks for clarifying
Comment 4 Gert Van Waelvelde 2016-06-30 08:54:52 UTC
Could someone check whether this document displays correctly in MS Word?
It is does, this is a LO bug. If it looks the same in Word, this is not a bug.

Thanks.
Comment 5 E.Mi 2016-06-30 09:11:03 UTC
I can't check unfortunately.
Comment 6 Gert Van Waelvelde 2016-06-30 09:34:28 UTC
(In reply to ekari from comment #5)
> I can't check unfortunately.

Hello,
Maybe somebody else can check it. We need to make sure that this problem is specific to LibreOffice. If it appears in Word as well, it may not be a bug. It could be that the person who created the document didn't do a good job with the formatting.
Comment 7 Gert Van Waelvelde 2016-06-30 20:29:10 UTC
Summary/description of this bug:

1) Open this document
2) The part of the line just underneath the logo in the header appears lower than the rest of the line (see screenshot).

This document displays properly in MS Word.
Comment 8 Telesto 2017-06-14 18:35:46 UTC
Repro with 4.0.0.3 and LibreOffice 3.3.0
Comment 9 Xisco Faulí 2017-06-15 10:32:10 UTC
Moving to NEW as per comment 8
Comment 10 QA Administrators 2018-06-16 02:45:50 UTC Comment hidden (obsolete)
Comment 11 Xisco Faulí 2019-06-27 09:57:47 UTC
Still reproducible in

Version: 6.4.0.0.alpha0+
Build ID: ea19b0c0230fcc730245ecd445c03164cb6a1d18
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 NISZ LibreOffice Team 2021-02-03 11:43:13 UTC
Created attachment 169423 [details]
Screenshot of the original document side by side in Word and Writer

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 318d384c596c1593667d6c936f55bf6ebd0c5db6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-GB
Calc: CL

The image is wrapped in Word as "the same line with text" (in Writer this is imported as anchor as character).

The line below it is a sequence of underscores without spaces. Thus it is considered as one word when it comes to wrapping the image.

Word seems to wrap the long word into the next line if it would not fit in the same line with the image.
Writer just breaks the long word at the end of the same line as the image is.
Comment 13 NISZ LibreOffice Team 2021-02-03 11:45:03 UTC
Created attachment 169424 [details]
Minimized example file

Minimized example shows the behavior is the same in the document body as well.

Also the difference between a long word (sequence of underscores) not fitting in one line with the image vs the behavior when it just fits.
Comment 14 NISZ LibreOffice Team 2021-02-03 11:45:45 UTC
Created attachment 169425 [details]
Screenshot of the minimized example side by side in Word and Writer
Comment 15 Commit Notification 2022-04-28 09:48:39 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/41b012767feb8552b60a68c7be18d80c403304bf

tdf#100680 sw DOCX compatibility: fix wrap of as_char flys

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 NISZ LibreOffice Team 2022-04-29 07:49:40 UTC
Verified in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 83d0f2eebae41d431d9a5bfd1a918523977752d0
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL