Bug 100783 - Crash in Remote Files dialog with SharePoint 2013
Summary: Crash in Remote Files dialog with SharePoint 2013
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-06 11:46 UTC by Andras Timar
Modified: 2016-10-25 18:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2016-07-06 11:46:04 UTC
In LibreOffice, add SharePoint 2013 CMIS service, replace <host> with <server>/<path-to>/<site-name>:
    e.g. http://sharepoint2013/sites/cbra/_api/Web
-> crash occurs in Remote Files dialog. LibreOffice simply vanishes. Reproducible since 5.1.0.3. 

Proposed fix:
https://gerrit.libreoffice.org/#/c/26977/
Comment 1 Julien Nabet 2016-07-07 10:28:39 UTC
Let's put this one to ASSIGNED since there's a patch in review.
Comment 2 Commit Notification 2016-07-07 19:50:23 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1a32a01be704cf91ec1c2b779f21784e8c443a7

tdf#100783 Avoid infinite recursion in Content::getObject()

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.