Download it now!
Bug 100802 - Overlapping text when editing numeric cell
Summary: Overlapping text when editing numeric cell
Status: RESOLVED DUPLICATE of bug 100925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-08 02:02 UTC by Dan Dascalescu
Modified: 2017-04-13 20:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Press F2 on B2 (32.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-08 02:02 UTC, Dan Dascalescu
Details
Overlapping text in B2 after pressing F2 (28.70 KB, image/png)
2016-07-08 02:03 UTC, Dan Dascalescu
Details
Overlapping text in B2 after pressing F2, in LO Dev 5.2.1.0+ (1.04 MB, image/gif)
2016-08-03 07:30 UTC, Dan Dascalescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2016-07-08 02:02:15 UTC
Created attachment 126113 [details]
Press F2 on B2

Open the attached file, click on B2, then press F2.

The number will be overwritten with a few digits. No idea where the come from; if I delete row 1, the problem won't be reproduced.

Ubuntu 16.04 64-bit.
Comment 1 Dan Dascalescu 2016-07-08 02:03:55 UTC
Created attachment 126115 [details]
Overlapping text in B2 after pressing F2
Comment 2 Joel Madero 2016-07-08 04:57:43 UTC
Version: 5.3.0.0.alpha0+
Build ID: dc4797a79e3f465e1fa930be7c69d8ec7d91c15e
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

Can't reproduce. F2 just toggles edit mode so the underlying number to me looks like a "15" which would make sense given the value in the cell. 

If you could try daily that would be great: http://dev-builds.libreoffice.org/daily/
Comment 3 Buovjaga 2016-07-16 17:34:18 UTC
I reproduce.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ab1b351840160655a9f0caedbb35e9fdf203c5a0
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 16th 2016

64-bit, KDE Plasma 5
Build ID: 5.1.4.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 4 Dan Dascalescu 2016-08-03 07:30:00 UTC
Created attachment 126535 [details]
Overlapping text in B2 after pressing F2, in LO Dev 5.2.1.0+

Reproduced in today's Dev.

All I'm doing is pressing F2 and Esc repeatedly. Most of the time, there are display artifacts over the cell.
Comment 5 kchin80 2017-04-13 15:42:02 UTC
Problem still persists in latest 5.3.2. SAL_USE_VCLPLUGIN is kde4.

When editing the cells in the initial viewport, it is fine. The moment the viewport has moved, e.g. scroll down or scroll right, the overlap text will appear when editing cell. When move back to initial viewport, it will work fine once again.
Comment 6 Buovjaga 2017-04-13 20:13:59 UTC
This report is older, but I will dupe to a slightly newer one as it has more information.

*** This bug has been marked as a duplicate of bug 100925 ***