Bug 100812 - Application close after insert graph
Summary: Application close after insert graph
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 100833 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-07-08 10:53 UTC by Pavel Spálený
Modified: 2016-08-24 22:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
One of files with problem (11.33 KB, application/vnd.ms-excel.12)
2016-07-08 10:53 UTC, Pavel Spálený
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Spálený 2016-07-08 10:53:22 UTC
Created attachment 126126 [details]
One of files with problem

When I try to insert graph or edit existing graph, application close. If I right click on graph and choose Edit (in Czech - Upravit), it's the same.

It's on attached file. But not only on this file. No error. Only dialog to restore data.

Win 7 x64.
Comment 1 Joel Madero 2016-07-08 14:15:35 UTC
Version: 5.3.0.0.alpha0+
Build ID: dc4797a79e3f465e1fa930be7c69d8ec7d91c15e
CPU Threads: 2; OS Version: Linux 3.16; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

No crash when I do this:

1. Open file;
2. Right click on graph;
3. Left click on edit.
Comment 2 mitchfx 2016-07-08 18:00:25 UTC
I can confirm this is an issue. I also see Calc crash immediately after trying to insert a graph. 

OS: Windows 10 (64-bit)
LibreOffice version: 5.1.4.2 release

I've tried with a selection and without a selection. Without a selection the crash is immediate. With some cells selected I actually see the graph show up and then the crash occurs.
Comment 3 Aron Budea 2016-07-12 00:52:16 UTC
I can't reproduce with LibreOffice 5.1.4.2 32-bit/ Windows 7 64-bit.

Can you try getting a backtrace of the crash?
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 4 Pavel Spálený 2016-07-12 09:27:46 UTC
I'm not sure if this is what you need:
Exception thrown at 0x76AEC54F (KernelBase.dll) in soffice.bin: 0x000006C6: Indexy pole nejsou v mezích. (to EN: Index of array is not in limits)
The thread 0x1d1c has exited with code 0 (0x0).
The thread 0x4654 has exited with code 81 (0x51).
The thread 0x5308 has exited with code 81 (0x51).
The thread 0x5b4 has exited with code 81 (0x51).
The thread 0x404c has exited with code 81 (0x51).
The thread 0x3a40 has exited with code 81 (0x51).
The thread 0x5a4c has exited with code 81 (0x51).
The thread 0x5584 has exited with code 81 (0x51).
The thread 0x4130 has exited with code 81 (0x51).
The thread 0x578c has exited with code 81 (0x51).
The thread 0x1e48 has exited with code 81 (0x51).
The thread 0x5be0 has exited with code 81 (0x51).
The thread 0x3d70 has exited with code 81 (0x51).
The thread 0x1e00 has exited with code 81 (0x51).
The thread 0x5874 has exited with code 81 (0x51).
The thread 0x5960 has exited with code 81 (0x51).
The thread 0x4d38 has exited with code 81 (0x51).
The thread 0x5418 has exited with code 81 (0x51).
The thread 0x2a2c has exited with code 81 (0x51).
The thread 0x3cb0 has exited with code 81 (0x51).
The thread 0x4078 has exited with code 81 (0x51).
The thread 0x35f8 has exited with code 81 (0x51).
The thread 0x566c has exited with code 81 (0x51).
The thread 0x2718 has exited with code 81 (0x51).
The thread 0xba8 has exited with code 81 (0x51).
The program '[5568] soffice.bin' has exited with code 81 (0x51).
Comment 5 Buovjaga 2016-07-16 18:06:01 UTC
(In reply to Pavel Spálený from comment #4)
> I'm not sure if this is what you need:

Nope. Just go through the "First time setup" in the wiki article.

I noticed another report about this: bug 100833
Comment 6 Pavel Spálený 2016-07-17 09:11:02 UTC
The bug (In reply to Buovjaga from comment #5)
> (In reply to Pavel Spálený from comment #4)
> > I'm not sure if this is what you need:
> 
> Nope. Just go through the "First time setup" in the wiki article.
> 
> I noticed another report about this: bug 100833

Yes - the bug 100833 is the same.
Comment 7 Buovjaga 2016-07-17 09:55:57 UTC
*** Bug 100833 has been marked as a duplicate of this bug. ***
Comment 8 Buovjaga 2016-07-17 09:56:52 UTC
Yeah, let's set to NEW and hope someone produces a backtrace.
Please also test with 5.2 http://www.libreoffice.org/download/pre-releases/
Comment 9 Pavel Spálený 2016-07-17 21:44:56 UTC
(In reply to Buovjaga from comment #8)
> Yeah, let's set to NEW and hope someone produces a backtrace.
> Please also test with 5.2 http://www.libreoffice.org/download/pre-releases/

In pre-releas is OK!
Comment 10 Buovjaga 2016-07-18 08:59:26 UTC
Thanks, Pavel! Let's close as WFM.