Bug 100835 - Not all Latin Modern subfonts / font weights available
Summary: Not all Latin Modern subfonts / font weights available
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-10 11:41 UTC by kingready
Modified: 2018-01-23 14:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
"17 Regular" cannot be chosen at the typefaces section (75.15 KB, image/png)
2016-07-10 11:41 UTC, kingready
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kingready 2016-07-10 11:41:19 UTC
Created attachment 126149 [details]
"17 Regular" cannot be chosen at the typefaces section

Steps to reproduce:

1. Download and install the complete Latin Modern font package: http://www.gust.org.pl/projects/e-foundry/latin-modern/download (second link)

2. Open LibreOffice Writer, write some text and try to apply the font "Latin Modern Roman 17 Regular"

Expected Result: The "Character Style" window should offer all subfonts provided by the font package (e. g. when choosing "Latin Modern Roman" as font family, you should be able to choose between "17 Regular", "10 Regular", "12 Regular", ... at the typefaces section)

Actual Result: The "Character Style" window looks like the attached screenshot. It offers only some of the installed fonts and there is no way to choose any other of the installed ones (e. g. "17 Regular").
Comment 1 Alex Thurgood 2016-07-18 07:47:33 UTC
Confirming in

Version: 5.3.0.0.alpha0+
Build ID: 33d58de8c05d7a3591ac81164c1786d183a09991
CPU Threads: 2; OS Version: Mac OS X 10.11.5; UI Render: default; 
Locale: fr-FR (fr.UTF-8)

Problems relating to incomplete font weight support are already known for certain OTF fonts in LibreOffice on OSX.
Comment 2 Alex Thurgood 2016-07-18 07:57:33 UTC
(In reply to Alex Thurgood from comment #1)
> Confirming in
> 
> Version: 5.3.0.0.alpha0+
> Build ID: 33d58de8c05d7a3591ac81164c1786d183a09991
> CPU Threads: 2; OS Version: Mac OS X 10.11.5; UI Render: default; 
> Locale: fr-FR (fr.UTF-8)
> 
> Problems relating to incomplete font weight support are already known for
> certain OTF fonts in LibreOffice on OSX.

See, for example, bug 69254
Comment 3 Alex Thurgood 2016-09-06 09:49:02 UTC
Can we mark this as a duplicate of bug 69254
Comment 4 Xisco Faulí 2017-09-29 08:51:06 UTC Comment hidden (obsolete)
Comment 5 Thomas Linard 2018-01-05 10:01:41 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 6 Thomas Linard 2018-01-23 14:03:01 UTC

*** This bug has been marked as a duplicate of bug 69254 ***