Download it now!
Bug 100892 - "Go to page or object" Not Clickable in PDF
Summary: "Go to page or object" Not Clickable in PDF
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-07-13 08:47 UTC by Biolardi Yoshogi
Modified: 2019-03-16 21:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF from lo 6.3 (8.65 KB, application/pdf)
2019-03-16 21:05 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Biolardi Yoshogi 2016-07-13 08:47:08 UTC
Object which has "Go to page or object" action in Interaction (by right clicking object), isn't clickable when exported to PDF.

I used Foxit Reader and Chrome PDF reader to view the PDF, but the results were same.

How to reproduce:
1. Make an image object or text object on a slide
2. Right click object -> Interaction..
3. On "Action at mouse click" -> Choose "Go to page or object"
4. On "Target" choose a slide, then click OK
5. File -> Export as PDF...
6. Export
7. Open the PDF File
8. Try to click the object (which was added with Interaction)
Comment 1 Buovjaga 2016-07-18 04:01:16 UTC
This might be seen as a feature request, but ok.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ab1b351840160655a9f0caedbb35e9fdf203c5a0
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 16th 2016
Comment 2 Aron Budea 2016-08-09 00:31:09 UTC
Since other Go to... interactions seem to work during PDF conversion, this is more of a bug.

Also reproduced back in v3.3.
Comment 3 QA Administrators 2017-09-01 11:18:27 UTC Comment hidden (obsolete)
Comment 4 Roman Kuznetsov 2019-03-16 21:04:22 UTC
It's WFM in

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 13a260f59e421f3e67845f8f2eb22b8f0f8fcaf0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-11_02:46:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 5 Roman Kuznetsov 2019-03-16 21:05:37 UTC
Created attachment 150018 [details]
PDF from lo 6.3

Click to blue shape on third page. You should move to first page of PDF