Bug 100943 - Copy/ Pasting and Moving Slides become slow as presentation is becoming more complex (Ubuntu Unity)
Summary: Copy/ Pasting and Moving Slides become slow as presentation is becoming more ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-16 06:00 UTC by Ljiljan
Modified: 2017-05-18 10:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Working file (858.99 KB, application/vnd.oasis.opendocument.presentation)
2016-07-18 09:12 UTC, Ljiljan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2016-07-16 06:00:54 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36
Build Identifier: LibreOffice 5.1.4.2

Under Ubuntu 16.04 (Unity interface), as your presentation is becoming larger doing following actions is very slow: 
- Copy/ Pasting 
- Moving Slides in Slide Panel

Removing libreoffice-gnome, libreoffice-gtk and libreoffice-gtk3 solve the issue. However, LibreOffice does not look great anymore (more like Windows 95 style). 

Reproducible: Always

Steps to Reproduce:
1. Create Complex Presentation under Ubuntu 16.04 (with Unity interface) 
2. Include drawings, images, tables (In my case I have 80 slides)
3. Open some slides. Copy-Paste. 
Actual Results:  
The first slide could copy very fast... but as you move through your presentation, the copy-paste or moving slides is taking up to 5 seconds making your processor busy. 

Expected Results:  
There is no delay in copying or moving slides. 

[Information automatically included from LibreOffice]
Locale: en-US
Module: PresentationDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Buovjaga 2016-07-16 20:26:55 UTC
Could you attach an example document so everyone does not have to create their own from scratch?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 David Tardon 2016-07-18 07:51:21 UTC
I believe I fixed this with https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=fd99dc83659b8c9e4dff9c55ed43c936f9a5b7fd . At least the symptoms are the same.
Comment 3 Ljiljan 2016-07-18 09:12:05 UTC
Created attachment 126270 [details]
Working file

How to reproduce the bug:

1. Open presentation
2. Go through each slide (Page Down, there is no need to do anything)
3. Select some slides on Side Panel and do Copy/ Paste
4. Repeat step 3 until you notice that copying/ moving is taking more time
Comment 4 Buovjaga 2016-07-18 09:14:00 UTC
(In reply to David Tardon from comment #2)
> I believe I fixed this with
> https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;
> h=fd99dc83659b8c9e4dff9c55ed43c936f9a5b7fd . At least the symptoms are the
> same.

Ljiljan: Can you confirm it is fixed for you in 5.2? http://www.libreoffice.org/download/pre-releases/
Comment 5 Ljiljan 2016-07-18 11:03:55 UTC
(In reply to Buovjaga from comment #4)
> (In reply to David Tardon from comment #2)
> > I believe I fixed this with
> > https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;
> > h=fd99dc83659b8c9e4dff9c55ed43c936f9a5b7fd . At least the symptoms are the
> > same.
> 
> Ljiljan: Can you confirm it is fixed for you in 5.2?
> http://www.libreoffice.org/download/pre-releases/

I cannot confirm because:
 - "error while loading shared libraries: libdbus-glib-1.so.2" (installation of pre-release version from official web page, "sudo dpkg...") - cannot start or solve this issue without damaging my system
- installing from pre-release PPA leads to unistallation of libreoffice-gnome, libreoffice-gtk and libreoffice-gtk3 (under these conditions problem do not exist)
- LibreOffice snap packages behave unstable even without this.
Comment 6 Ljiljan 2016-07-21 06:00:26 UTC
I did test with latest Snap LibreOffice (https://skyfromme.wordpress.com/2016/07/18/libreoffice-5-2-0-2-available-in-the-snap-store/). This snap package is capable of opening presentation and is not crashing. However, the problem stil exists (though it is less obvious than previous version of LibreOffice). I believe it has to do something with libreoffice-gtk3.
Comment 7 Ljiljan 2016-08-15 05:45:22 UTC
I didn't notice this error in LibreOffice 5.2.
Comment 8 Cor Nouws 2016-08-15 06:37:49 UTC
no clear related commit > WorksForMe
Comment 9 Antonio Cañas 2017-05-17 10:38:25 UTC
In Ubuntu 16.04, with version 5.1.6.2 of LibreOffice, the problem persists: when the presentation has more than 150 slides with images (90 MB), deleting, copying, pasting or duplicating a slide puts the CPU at 100% for about 5 minutes.
Comment 10 Buovjaga 2017-05-17 10:48:18 UTC
(In reply to Antonio Cañas from comment #9)
> In Ubuntu 16.04, with version 5.1.6.2 of LibreOffice, the problem persists:
> when the presentation has more than 150 slides with images (90 MB),
> deleting, copying, pasting or duplicating a slide puts the CPU at 100% for
> about 5 minutes.

Use 5.2 or 5.3, not 5.1.
Comment 11 Antonio Cañas 2017-05-18 10:44:21 UTC
(In reply to Buovjaga from comment #10)
> (In reply to Antonio Cañas from comment #9)
> > In Ubuntu 16.04, with version 5.1.6.2 of LibreOffice, the problem persists:
> > when the presentation has more than 150 slides with images (90 MB),
> > deleting, copying, pasting or duplicating a slide puts the CPU at 100% for
> > about 5 minutes.
> 
> Use 5.2 or 5.3, not 5.1.

OK, thanks! I usually let Ubuntu automatically update packages and version 5.1.6.2 (1: 5.1.6 ~ rc2-0ubuntu1 ~ xenial2) is the latest in Ubuntu 16.04.