Bug 100987 - Hide Row and Show Row operations lose cell-anchored images
Summary: Hide Row and Show Row operations lose cell-anchored images
Status: RESOLVED DUPLICATE of bug 98931
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2016-07-18 15:07 UTC by Jan_J
Modified: 2018-01-24 08:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sheet 1 has images anchored to some cells in column B. Rows 2-3 are hidden. After making them visible, the images are not put back to the page. They appear after second save, close and reload. (177.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-18 15:07 UTC, Jan_J
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan_J 2016-07-18 15:07:57 UTC
Created attachment 126282 [details]
Sheet 1 has images anchored to some cells in column B. Rows 2-3 are hidden. After making them visible, the images are not put back to the page. They appear after second save, close and reload.

A spreadsheet page has been created with several images anchored to cell in specified column.
(1) Using <Hide Rows> command from the local menu causes images adjacent to marked rows invisible. (2) Similarly, <Show rows> reveals them back.
But if we save and close workbook after stage (1), and then reopen it, stage (2) does not make images visible.
This does not mean that images are lost. They are still contained in the document file. When we (3) save workbook again after showing hidden rows, close it and reopen once more, images are in place. At least in my tests.

Tested under Calc 5.0.5, 5.1.4, Windows, Linux (rpm)
Comment 1 m.a.riosv 2016-07-18 15:48:20 UTC
Reproducible
Win10x64
Version: 5.1.5.1 (x64)
Build ID: bb431b2be5fb7772067efc27a3cc98b6927c7b4c
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: CL
Comment 2 m.a.riosv 2016-07-18 16:02:07 UTC
Not exactly the same behavior but it never works fine, for 4.1 and before.
Comment 3 Cor Nouws 2018-01-24 08:38:03 UTC
looking at https://bugs.documentfoundation.org/show_bug.cgi?id=98931#c26, I set this one as duplicate

*** This bug has been marked as a duplicate of bug 98931 ***