Bug Hunting Session
Bug 100996 - Tools -> Solver... does not display message anymore if no compatible Java installed
Summary: Tools -> Solver... does not display message anymore if no compatible Java ins...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2016-07-19 00:42 UTC by Aron Budea
Modified: 2017-03-17 07:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-07-19 00:42:38 UTC
Bug 98619 was submitted about Calc exiting abruptly after displaying an error message if Java is not installed, and Tools -> Solver... is opened.

This bug is gone by 5.2, eg. there's the message as expected, and Calc doesn't quit, but in 5.3 master build (Build ID: be232a1b76fb263d17d2e52a420b6aba7272f3fd) there's no message at all, which is a new issue.
Comment 1 Yousuf Philips (jay) (retired) 2016-10-29 14:02:39 UTC
Cant reproduce on Win XP. Hopefully its not a regression that was introduced in the last 10 days. ;D

@Aron: Would suggest also including the build date along with the build id, as i (assume others as well) dont know how to find the date from the build id.

Version: 5.3.0.0.alpha0+
Build ID: 4a74c8af0b4573b4b72ccf04b26c71e41799e7a0
CPU Threads: 1; OS Version: Windows 5.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-10-19_12:19:28
Locale: en-JM (en_JM); Calc: group

@Stuart, @Buovjaga, @Heiko: How about you guys?

On a separate note, is java required for the solver, and if so, the solver dialog shouldnt appear if it isnt installed.
Comment 2 Aron Budea 2016-10-29 14:53:08 UTC
The bug report is from July, so definitely not introduced in the last 10 days :). Might be fixed, though... so what do you mean by you not being able to reproduce? You don't have Java installed, and what happens exactly if you open Solver?

If you get the proper message, and it doesn't let you start Solver, this report can probably be closed as WFM.

Here's the way to find the date from the build id (which is the latest commit the build contains):
https://cgit.freedesktop.org/libreoffice/core/commit/?id=be232a1b76fb263d17d2e52a420b6aba7272f3fd
Comment 3 Yousuf Philips (jay) (retired) 2016-10-29 15:30:53 UTC
(In reply to Aron Budea from comment #2)
> The bug report is from July, so definitely not introduced in the last 10
> days :).

Well i didnt notice the date of issuing of the bug, but would have noticed the build date if you had pasted it. :D

> Might be fixed, though... so what do you mean by you not being able
> to reproduce? You don't have Java installed, and what happens exactly if you
> open Solver?

I saw the java error dialog, as i dont have java installed.

> If you get the proper message, and it doesn't let you start Solver, this
> report can probably be closed as WFM.

The solver dialog appeared after the java error dialog, so i guess this hasnt been resolved. I see the solver dialog also in 5.2.1.2.
Comment 4 Heiko Tietze 2016-10-30 09:09:40 UTC
(In reply to Yousuf Philips (jay) from comment #1)
> @Heiko: How about you guys?

Solver shows up, no Java on my system.

Version: 5.3.0.0.alpha0+
Build ID: d2081e8b61bbe982f4e0977c2b46e00ccf19732f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

(daily build won't start today)
Comment 5 Heiko Tietze 2016-10-30 09:25:24 UTC
(In reply to Heiko Tietze from comment #4)
> ...no Java on my system.

That's wrong. I have openjdk version "1.8.0_112" installed, which is listed properly in LibO fresh but not in my own build since I compile --without-java.
Comment 6 Buovjaga 2016-11-19 19:54:03 UTC
I did not get the message. I just installed Win 10 on a VM, so there is no trace of Java yet.

Version: 5.3.0.0.alpha1+
Build ID: 395295a40c24a49c12415ec803860a888d734515
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-18_01:30:57
Locale: fi-FI (fi_FI); Calc: group
Comment 7 Aron Budea 2017-03-05 01:28:35 UTC
Tested now with 5.3.0.3, without Java installed. Got the message as expected. Closing as WFM.