Download it now!
Bug 100999 - Links to cells in other files corrupted in xlsx documents
Summary: Links to cells in other files corrupted in xlsx documents
Status: RESOLVED DUPLICATE of bug 76047
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-19 04:41 UTC by Andrew
Modified: 2016-07-19 21:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2016-07-19 04:41:03 UTC
Create two files test2.xls and test2.xlsx.  Place value "42" in cell A1.

Create file test1.xls. Paste in cell A1 a link to cell A1 in test2.xls and in cell A2 a link to cell A1 in test2.xlsx.  Save and close file.  Open it again.  This works OK.

Save test1.xls as test1.xlsx.  Close test1.xlsx, and then open it again.  The links get corrupted, e.g.:

='file:///C:/Users/Andrew/Documents/Finance/Andrew/FY16/test2.xls'#$Sheet1.A1

becomes

='file:///C:/Users/Andrew/Documents/Finance/Andrew/FY16/1'#$Sheet1.A1
Comment 1 m.a.riosv 2016-07-19 21:44:28 UTC

*** This bug has been marked as a duplicate of bug 76047 ***