Download it now!
Bug 101032 - [UI] Page pane renders are dirty since version 5.1.x
Summary: [UI] Page pane renders are dirty since version 5.1.x
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-07-20 11:09 UTC by Carlo Strata
Modified: 2016-08-05 08:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
my draw public video-surveillance system project (35.71 KB, application/vnd.oasis.opendocument.graphics)
2016-07-20 11:09 UTC, Carlo Strata
Details
Page Pane, zoom level 1, KO render (143.89 KB, image/png)
2016-07-20 11:11 UTC, Carlo Strata
Details
Page Pane, zoom level 2, KO render (146.15 KB, image/png)
2016-07-20 11:12 UTC, Carlo Strata
Details
Page Pane, zoom level 3, OK render! (144.17 KB, image/png)
2016-07-20 11:13 UTC, Carlo Strata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Strata 2016-07-20 11:09:55 UTC
Created attachment 126318 [details]
my draw public video-surveillance system project

Hi Everyone,

in Draw at certain "page pane" zoom levels, the page pane render are slightly dirty.

I will attach my draw public video-surveillance system project and some screenshots (KO 1, KO 2, and OK 3) to explain the bugs.

I see this behavior since version 5.1.x (I don't remember my first version of that branch) and now in version 5.2.0.2, too.

The bug doesn't exist (I never saw it) in branch 5.0.x!!!

My system is:
- Microsoft Windows 10, x64, ita, home, version 1511, build 10586.494, daily updated;
- LibreOffice Version: 5.2.0.2 (x64), Build ID: a7567a46e5d2953c320b13eb88a3981c4f9bd1e0, CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Locale: it-IT (it_IT)

Have all a nice day,

Carlo
Comment 1 Carlo Strata 2016-07-20 11:11:50 UTC
Created attachment 126319 [details]
Page Pane, zoom level 1, KO render
Comment 2 Carlo Strata 2016-07-20 11:12:36 UTC
Created attachment 126320 [details]
Page Pane, zoom level 2, KO render
Comment 3 Carlo Strata 2016-07-20 11:13:17 UTC
Created attachment 126321 [details]
Page Pane, zoom level 3, OK render!
Comment 4 Carlo Strata 2016-07-20 11:14:06 UTC
Comment on attachment 126318 [details]
my draw public video-surveillance system project

test case document
Comment 5 Heiko Tietze 2016-07-21 09:37:12 UTC
No issue with LibO fresh and master here with your document. The thumbnails scale nicely without any flyspeck.

Version: 5.1.4.2
Build ID: 5.1.4.2 Arch Linux build-1

Version: 5.3.0.0.alpha0+
Build ID: 3697ddaf798d2aeea2777bb3a8eba33edca7acb4
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

(LXQt runnning on kwin)
Comment 6 Buovjaga 2016-07-28 19:05:45 UTC
Yep, no problem. Maybe I have to try on Win later.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: c1b665fcdacd4141137f1e369527e2c0d94513ae
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 26th 2016
Comment 7 Buovjaga 2016-08-02 11:48:21 UTC
Could not reproduce.

Win 7 Pro 64-bit, Version: 5.1.3.2 (x64)
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)

Version: 5.3.0.0.alpha0+
Build ID: cf0fea5546c9b6b30d18deb084ddaa5e08aad41b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-07-30_23:31:05
Locale: fi-FI (fi_FI); Calc: CL
Comment 8 Heiko Tietze 2016-08-05 08:36:13 UTC
The artifact may be related to antialiasing, which is reported somewhere else to affect drawings. NOTOURBUG since it also could be an issue of the graphic driver.