Bug Hunting Session
Bug 101056 - Tabbing through sheets loses selection
Summary: Tabbing through sheets loses selection
Status: RESOLVED DUPLICATE of bug 64345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-UX
  Show dependency treegraph
 
Reported: 2016-07-21 10:00 UTC by Dan Dascalescu
Modified: 2017-07-15 20:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Dascalescu 2016-07-21 10:00:51 UTC
1. Have a spreadsheet with two sheets and dome date.
2. In one sheet, select a few cells
3. Press Ctrl+PgDn, then Ctrl+PgUp to get back to the initial sheet.

Notice that the selection is gone. For the same operation, Excel preserves the selection.
Comment 1 Aron Budea 2016-07-22 07:33:44 UTC
Reproduced with as early as LibreOffice 3.3.
Since it doesn't seem to be affecting the ability to make high quality work, adjusting importance accordingly.
Comment 2 Dan Dascalescu 2016-08-03 07:11:32 UTC
This bug affects my workflow in various scenarios:

1. When checking if the sum of a list of cells is the same across two different tabs

2. Worse, when selecting disparate cells while checking something in a different sheet, this careful manual selection is lost. Lists of adjacent cells are not that big of a deal, as I can easily select them again. But if I select specific cells and that selection is lost if I change the sheet, that becomes frustrating really quickly.
Comment 3 Aron Budea 2016-08-03 09:04:09 UTC
Thanks for giving details on how this bug could impact users, I wasn't sure at first.
I'm bumping importance (using this chart for general prioritization: https://wiki.documentfoundation.org/File:Prioritizing_Bugs_Flowchart.jpg ).
Comment 4 Thomas Lendo 2017-07-15 20:58:56 UTC

*** This bug has been marked as a duplicate of bug 64345 ***