Bug Hunting Session
Bug 101091 - Table with merged cell: deleting rows is inconsistent with deleting columns
Summary: Table with merged cell: deleting rows is inconsistent with deleting columns
Status: RESOLVED DUPLICATE of bug 46733
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2016-07-23 17:34 UTC by Heinrich Hartl
Modified: 2019-04-19 16:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test case and instructions for reproduction (20.93 KB, application/vnd.oasis.opendocument.text)
2016-07-23 17:34 UTC, Heinrich Hartl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heinrich Hartl 2016-07-23 17:34:45 UTC
Created attachment 126378 [details]
test case and instructions for reproduction
Comment 1 Buovjaga 2016-07-28 19:17:08 UTC
Reproduced and I agree it would be good to have column deletion follow the logic of row deletion in case of merged cells.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: c1b665fcdacd4141137f1e369527e2c0d94513ae
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 26th 2016
Comment 2 QA Administrators 2017-09-01 11:19:57 UTC Comment hidden (obsolete)
Comment 3 Heinrich Hartl 2018-02-15 11:18:49 UTC
Comment on attachment 126378 [details]
test case and instructions for reproduction

Problem still exists but behaviour is different under 
Version: 5.3.7.2 (x64)
Build-ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU-Threads: 4; BS-Version: Windows 6.1; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group

While it is still possible to delete Row 2
deletion of culumn 2 in the mirrored table is now forbidden (delete column is greyed out)
This change of behaviour is not improving the situation. The desired result is not achieved and I can not see how to achieve it... (no bypass solution!)
Comment 4 Buovjaga 2019-04-19 16:06:47 UTC

*** This bug has been marked as a duplicate of bug 46733 ***