Bug 101107 - Editing Connectors seems to mess with LightDM - Affects all other apps on the PC
Summary: Editing Connectors seems to mess with LightDM - Affects all other apps on the PC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: Connectors
  Show dependency treegraph
 
Reported: 2016-07-25 05:26 UTC by Aaron Duerksen
Modified: 2020-05-07 20:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Duerksen 2016-07-25 05:26:42 UTC
User-Agent:       Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build Identifier: LibreOffice 5.1.4.2

On a dual-monitor setup, editing a connector seems to be a finite chance of putting the global display manager into a weird state so that:
- the cursor is updated like it's supposed to
- the rest of the display is not updated until I click on the other monitor, but then it's accurate according to what I did blindly
The problem then persists for all apps, not just LibreOffice.
Logging out and back in always fixes it.
Only connectors seem to have this problem: editing other objects appears to be completely safe, even if moving something that has a connector attached to it.  Just as long as the connector is not directly being edited.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a Drawing that has some objects and attached connectors.
2. Edit those connectors by copy/pasting or moving their endpoints and routing.
3. Continue playing with connectors until the display stops updating.
4. Do something in an unrelated app on a different monitor.
5. LibreOffice display suddenly updates on focus loss, but the unrelated app appears frozen.
6. Click away from unrelated app's monitor.
7. Unrelated app now updates its display.
8. Log off and back on.
9. Repeat from #1 as needed for diagnostics.
Actual Results:  
See Steps to Reproduce

Expected Results:  
See Steps to Reproduce

[Information automatically included from LibreOffice]
Locale: en-US
Module: DrawingDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes


Reset User Profile?No
Comment 1 Aaron Duerksen 2016-07-25 06:48:11 UTC
It seems to have something to do with glue points too.  The display froze as soon as I selected the option to add one to an object.  This is before actually adding it or moving a connector to it.

As usual, I could add it blindly and move the connector to it with occasional clicks to the other monitor to explicitly refresh the display and check my work.
Comment 2 Heiko Tietze 2016-07-25 07:32:47 UTC
What desktop environment do you run? In case of KDE please update to 5.7.2, I read positive feedback regarding multiscreen...  Ignore this, you are on LightDM.

As you say the issue happens not only for Libreoffice. So it seems to be NOTOURBUG. Or am I wrong?
Comment 3 Aaron Duerksen 2016-07-25 07:36:46 UTC
It only starts when editing connectors or creating/editing gluepoints in LibreOffice.  That's why I think it's caused by LibreOffice.  Once it starts, it affects everything else.
Comment 4 Heiko Tietze 2016-07-25 08:22:30 UTC
I guess this issue will be hard to track down because multi-screen problems are often related to the hardware and to the very specific setup. For instance, Intel drivers are known to be much more buggy than Nvidia, and at some point I had to move my notebook from left-of to right-of the external display in order to cope with bugs when the lid is closed. And last but not least you are running a not so common desktop environment. I never experienced an issue like yours on KDE, LXQt or Windows.

So are you able to check against other desktop environments?
Comment 5 Aaron Duerksen 2016-07-25 09:24:08 UTC
My Windows 10 host machine seems to be okay.  It's a Dell laptop with both Intel (low power) and Nvidia (high performance) graphics.

The problem is in a fully-updated Lubuntu 16.04 LTS VirtualBox guest with the default display manager and a USB touchscreen mapped to its non-default monitor.  I'm not using the touch to produce the problem, but it is present and working.  Unmapping the touchscreen does not fix it.

I can't test anything else right now.
Comment 6 Elina Williams 2018-11-23 09:37:00 UTC Comment hidden (spam)
Comment 7 Chandu0009 2019-06-18 13:50:33 UTC Comment hidden (spam)
Comment 8 Buovjaga 2020-04-17 15:30:24 UTC
Aaron: can you try with Lubuntu 20.04: https://lubuntu.me/downloads/ ?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 9 Aaron Duerksen 2020-05-07 20:31:52 UTC
It took me a while to get back to this.  I hadn't used that virtual machine for years, as its purpose was done, but for some reason I kept it around.  I fully updated it, and I can't reproduce the problem anymore.

I also tried a new virtual machine with a fresh install of Lubuntu 16.04.3 and then 20.04, and I can't reproduce it there either.

So I guess we can call it fixed by accident?