Bug 101113 - Crash when switch between modes
Summary: Crash when switch between modes
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: accessibility, haveBacktrace, regression
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2016-07-25 14:57 UTC by Alex ARNAUD
Modified: 2017-05-03 13:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of the crash (12.89 KB, text/plain)
2016-07-25 14:57 UTC, Alex ARNAUD
Details
Orca debug file during the crash (219.79 KB, text/plain)
2016-07-26 10:21 UTC, Alex ARNAUD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2016-07-25 14:57:53 UTC
Created attachment 126401 [details]
Backtrace of the crash

Dear LibreOffice community,

Versions impacted : 
- LibreOfficeDev 5.3.0.0.alpha0 cb95159e79ee531f3908e30fefae73693672f0a6
- LibreOffice 5.1.4.2 10m0(Build:2)

when I switch between the normal mode to another mode (outline, note, ...), LO crashes.

Steps to reproduce : 
1) Open LibreOffice Impress
2) Add a slide with a title
3) Place your cursor inside the title pane
4) Open menu view
5) Choose outline or note

Result : LibreOffice crashes

FYI,as I see the problem doesn't appear in version 4.2 so it is a regression.

Best regards,
Alex.
Comment 1 Aron Budea 2016-07-26 07:15:19 UTC
Hi Alex! I can't reproduce this with version 5.1.4.2 in Ubuntu 15.10.

These were the steps I took:
(0. I enabled Orca.)
1. I opened Impress.
2. I added a new slide, just to make sure (wasn't sure if having the initial slide was enough or not), and added title "Test".
3. Cursor was already in title pane after second step.
4&5. Switched to View -> Outline, then View -> Note.

Let me know if my steps cause crash for you, or whether I'm missing something.

Note that I got a slightly different crash with 5.2.0.3 right when I clicked into the slide's title after Impress started. I kind of had to click quickly, if I waited a bit there was no crash, or sometimes it occurred after a double click. I'll open a new bug report on this one, it's probably unrelated to the crash you found.
Comment 2 Alex ARNAUD 2016-07-26 09:57:50 UTC
(In reply to Aron Budea from comment #1)
> Hi Alex! I can't reproduce this with version 5.1.4.2 in Ubuntu 15.10.
> 
> These were the steps I took:
> (0. I enabled Orca.)
> 1. I opened Impress.
> 2. I added a new slide, just to make sure (wasn't sure if having the initial
> slide was enough or not), and added title "Test".
> 3. Cursor was already in title pane after second step.
> 4&5. Switched to View -> Outline, then View -> Note.
> 
> Let me know if my steps cause crash for you, or whether I'm missing
> something.
> 
> Note that I got a slightly different crash with 5.2.0.3 right when I clicked
> into the slide's title after Impress started. I kind of had to click
> quickly, if I waited a bit there was no crash, or sometimes it occurred
> after a double click. I'll open a new bug report on this one, it's probably
> unrelated to the crash you found.

Hi Aron,

Do you know if you use the GTK2 or GTK3 version ? I use Orca 3.20.2 and the GTK2 version of LibreOffice, maybe you have another Orca release or LibreOffice.
I'll try in Ubuntu to give you another feedback.

Best regards,
Alex.
Comment 3 Alex ARNAUD 2016-07-26 10:21:51 UTC
Created attachment 126411 [details]
Orca debug file during the crash
Comment 4 Alex ARNAUD 2016-07-26 10:24:29 UTC
Dear all,

I've added Joanie in CC because effectively I cannot reproduce the issue on Ubuntu.
Maybe it is a AT-SPI2 crash. I use the version 2.14.0.

Best regards,
Alex.
Comment 5 Alex ARNAUD 2016-07-26 12:18:15 UTC
(In reply to Alex ARNAUD from comment #4)
> Maybe it is a AT-SPI2 crash. I use the version 2.14.0.

I've made test but even if I upgrade AT-SPI2 to version 2.20 the problem always appears.
I tested both version GTK2 and GTK3 with the same behavior. I've also tested with multiple Orca versions without any differences.
Comment 6 Aron Budea 2016-07-27 08:22:51 UTC
I admit my reproduction method has been very simple so far (and I don't know much about the tools involved apart from starting/stopping Orca).
My Ubuntu 15.10 install has Orca 3.16.3 and AT-SPI2 2.16, and I can only run LibreOffice with GTK2. I also tried with Ubuntu 16.04, without luck.

However, if as you mentioned you couldn't reproduce it in Ubuntu, maybe there is some other configuration difference. It's probably not worth looking into it too much, let's wait for someone with a different distribution to confirm it. Which distribution do you normally use, btw?

I'm upping severity, since the crash occurs for you. Removing needsDevEval tag, since that is for possible easy hacks.
Comment 7 Alex ARNAUD 2016-07-27 18:25:12 UTC
(In reply to Aron Budea from comment #6)
> I admit my reproduction method has been very simple so far (and I don't know
> much about the tools involved apart from starting/stopping Orca).
> My Ubuntu 15.10 install has Orca 3.16.3 and AT-SPI2 2.16, and I can only run
> LibreOffice with GTK2. I also tried with Ubuntu 16.04, without luck.
> 
> However, if as you mentioned you couldn't reproduce it in Ubuntu, maybe
> there is some other configuration difference. It's probably not worth
> looking into it too much, let's wait for someone with a different
> distribution to confirm it. Which distribution do you normally use, btw?
> 
> I'm upping severity, since the crash occurs for you. Removing needsDevEval
> tag, since that is for possible easy hacks.

Dear Aron,

You should take a look to my reply on the other bug : https://bugs.documentfoundation.org/show_bug.cgi?id=101132#c6

Best regards,
Alex.
Comment 8 Julien Nabet 2016-07-28 08:03:11 UTC
Aron: I had already tried this one but can't reproduce it, that's why I hadn't put myself in cc.
It seems I can't help at all with accessibility bugs.
(I'm responding about your comment from tdf#101132)
Comment 9 Julien Nabet 2016-07-29 07:35:03 UTC
Sorry I forgot to put info versions:
gnome-orca: 3.20.2-1
at-spi2-core: 2.20.2-1
(from Debian testing)
Comment 10 Alex ARNAUD 2016-08-01 16:00:26 UTC
(In reply to Julien Nabet from comment #8)
> Aron: I had already tried this one but can't reproduce it, that's why I
> hadn't put myself in cc.
> It seems I can't help at all with accessibility bugs.
> (I'm responding about your comment from tdf#101132)

Dear Julien and all,

I've tested with version 5.2 RC4 and the bug continue to appear.
The bug is really easy to reproduce on Debian 8.5 Jessie with accessiblity enabled and with Orca launched.

Best regards,
Alex.
Comment 11 Buovjaga 2016-08-05 19:33:36 UTC
My Orca in Ubuntu 16.04 is version 3.18.2.
I turned screen reader on and launched LibO with SAL_USE_VCLPLUGIN=gtk libreoffice and did the steps, but no crash.

I did get this to the terminal output:
** (soffice:16003): CRITICAL **: AtkObject* atk_object_wrapper_ref(const com::sun::star::uno::Reference<com::sun::star::accessibility::XAccessible>&, bool): assertion 'rxAccessible.get() != nullptr' failed

(soffice:16003): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

Version: 5.1.5.2
Build ID: 1:5.1.5~rc2-0ubuntu1~xenial1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 12 arnaud.malfoy 2016-10-09 05:25:42 UTC
I cannot reproduce the bug on Ubuntu 16.04.1 with
Version: 5.2.2.2
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 13 Timur 2017-05-03 11:49:29 UTC
This bug is still unconfirmed. Please retest with new versions. 
Since you found this to be regression, and bibisect is not possible if not reproducible for others, please use Bash Script from http://pastebin.com/L6SFSYFR to extract Parallel LO from downloaded and unzipped LO in order to exactly find when this started for you.
Comment 14 Alex ARNAUD 2017-05-03 13:36:23 UTC
(In reply to Timur from comment #13)
> This bug is still unconfirmed. Please retest with new versions. 
> Since you found this to be regression, and bibisect is not possible if not
> reproducible for others, please use Bash Script from
> http://pastebin.com/L6SFSYFR to extract Parallel LO from downloaded and
> unzipped LO in order to exactly find when this started for you.

Hello Timur,

Thanks to contact me about this issue.
What I can tell you are :
- LibreOfficeDev 5.4 crashes on Debian 8
- LibreOffice doesn't crash on Debian 9

Because Debian 9 will be release soon we could ignore this specific issue.

Best regards.