Bug Hunting Session
Bug 101141 - UI: Only Applications (file types) for templates but no template Categories can be selected/filtered in the Start Center
Summary: UI: Only Applications (file types) for templates but no template Categories c...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
: 101131 101306 (view as bug list)
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2016-07-26 20:55 UTC by ribotb
Modified: 2019-02-15 08:56 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
The problem and a suggestion... (225.41 KB, image/png)
2016-08-03 09:35 UTC, Ysabeau
Details
101141_ ScreenPrintStartCenterTemplates in daily20180203 (85.75 KB, image/png)
2018-02-06 13:14 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ribotb 2016-07-26 20:55:42 UTC
Hi,

From the start center, when clicking the 'Templates' button to open 'Template manager', the templates folders are no longer displayed. The thumbnails of templates contained in a folder are displayed directly.

Bernard
Comment 1 Samuel Mehrbrodt (CIB) 2016-07-27 06:57:14 UTC
This change is intended. You can filter by category (which are folders) on the top.
See https://akkidevblog.wordpress.com/2016/07/23/redesigning-the-template-manager/ for more details.
Comment 2 Ysabeau 2016-07-27 09:41:39 UTC Comment hidden (no-value)
Comment 3 Samuel Mehrbrodt (CIB) 2016-07-27 09:43:33 UTC
(In reply to Ysabeau from comment #2)
> And it is awful when you really use templates and have more that one or two,
> for example in a professional use!

Why? What exactly are you missing? You can still select the folders, but in a different place.
Comment 4 V Stuart Foote 2016-07-27 15:39:33 UTC
*** Bug 101131 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2016-07-27 15:43:40 UTC
See also discussion/comment in the Design ML thread

http://nabble.documentfoundation.org/Template-manager-tc4189237.html

Setting this to enhancement and NEW as the Template manager GUI is doing what it was redesigned to do--handling additional directory locations is a new facet simply not implemented.
Comment 6 Ysabeau 2016-07-27 15:47:13 UTC Comment hidden (no-value)
Comment 7 Samuel Mehrbrodt (CIB) 2016-07-27 17:41:10 UTC
(In reply to V Stuart Foote from comment #5)
> handling additional directory locations is a
> new facet simply not implemented.

??? Of course it is.
Comment 8 V Stuart Foote 2016-07-27 18:35:09 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #7)
> 
> ??? Of course it is.

@Samuel, Akshay

So working on Windows with a current build of Master...

A default installation will create share/template adding all bundled templates there, and a new default profile will create settings/user/template.

But to add other "external" sources of templates it seems we have to Import (or Export), and only then gain access to the file management (OS or LibreOffice dialogs) and when imported. 

Problem is that a copy gets dropped into a category defined per user profile settings/user/template. As is, it seems like there no way to link directly to a centralized template store on a network share.

The Paths dialog allows us to modify the Templates type and Add another location--but then that is limited to setting a default for newly templates.

It seems like we are missing ability to set alternate paths for Templates.  Or am I just not up to speed with the new UI?
Comment 9 Regina Henschel 2016-07-27 19:51:23 UTC
There is no problem adding external sources. It works as before by adding the path in Tools > Options > LO > Paths.
Assume you have:
Folder "myoffice" with files "one.ott" and "two.ott" and folders "Home" and "Job".
In folder "Home" is the file "three.ott" and the folder "Children".
In folder "Job" is the file "four.otp".
In folder "Children" is the file "five.otp".

If you add the path "myoffice", then the files "one.ott" and "two.ott", which are directly in folder "myoffice", are shown in category "My Templates".
The folders "Home" and "Job" are shown as category "Home" and "Job". The file "three.ott" is shown in category "Home" and the file "four.otp" is shown in category "Job". The folder "Children" and its content is not shown.

That is the same behavior as it has always been. Nothing changed. Even foreign templates like *.dotx or *.pot are detected and usable and manually created folders in "myoffice" will be detected at least on the next start of LibreOffice. Only the start center is a little bit confusing, because it collects all templates of the selected kind from all categories.

If you want to make a document on a template, which is not in a path, that is listed in Tool>Options>LO>Paths, that is possible too. Use File > Open. Then the document do not track on which template it is based. That too is not new, but is the same behavior as before.

The "import" enables you to copy an external template into users/template and assign it in the same step to a category. That is convenient, because you do not need to access the "users" folder manually, which would expect too much of some users.

So I really do not understand, what this issue is about.
Comment 10 ribotb 2016-07-31 20:49:45 UTC
(In reply to Regina Henschel from comment #9)
> 
> So I really do not understand, what this issue is about.

Originally, this issue is about the fact that the templates folders are no longer displayed in the Start Center. Samuel Mehrbrodt says "This change is intended". Ok, I note that.

Bernard
Comment 11 Yousuf Philips (jay) (retired) 2016-08-01 19:54:22 UTC
The folders will be available in a similar fashion as in the template manager with a search field and a drop down menu for folders/categories.
Comment 12 Ysabeau 2016-08-03 09:35:54 UTC
Created attachment 126540 [details]
The problem and a suggestion...

See the png file to understand all the problem, and a solution of what the template manager should show from the star centre.

I am quite sure that it shouldn't show files that have been deleted since ages and tmp files! And, yes, I verified several times that these files are no longer in the directory (nor in the dustbin or anything).
Comment 13 Ysabeau 2016-08-03 09:40:59 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> (In reply to Ysabeau from comment #2)
> > And it is awful when you really use templates and have more that one or two,
> > for example in a professional use!
> 
> Why? What exactly are you missing? You can still select the folders, but in
> a different place.

This a mess: if we store our templates in folders is to be able to find them more easily. If you have the bunch of templates (when you are a professional user of LibreOffice, you may have more than only one or two templates...) this windows is awful. Why not only show the templates manager? The will be better than the thing we no have.
Comment 14 Regina Henschel 2016-08-03 12:18:02 UTC
(In reply to ribotb from comment #10)
> Originally, this issue is about the fact that the templates folders are no
> longer displayed in the Start Center. Samuel Mehrbrodt says "This change is
> intended". Ok, I note that.
OK, I get it now. I have changed the subject. BTW, a category can contain files from different folders. The old version had shown categories, not folders.

And I agree, that the current solution needs improvement. Reasoning:(1) After you click on the item 'Templates' it takes a very long time, till all thumbnails are collected. For me it lasts 18 seconds! (2) Most of the templates, which come from the share folder, are irrelevant for common work. It would be sufficient to have a "All document types" item in the drop-down to get this total list on demand.


(In reply to Ysabeau from comment #13)
> If you have the bunch of templates (when you are a professional
> user of LibreOffice, you may have more than only one or two templates...)
> this windows is awful. Why not only show the templates manager? The will be
> better than the thing we no have.
Showing single template files has the advantage, that you can start with a single click. Therefore I do not think, that showing the template manager or showing categories (as before) would be better. But seeing this endless list of files (more than 190 in my case) is not good either. If we show thumbnails of template files, there need to be an additional way to determine, which templates are shown.

If you like to start with the template manager, do not click on 'Templates' but use short cut key 'Ctrl+Shift+N' or the item 'Template Manager' from the drop-down list.



(In reply to Ysabeau from comment #12)
> I am quite sure that it shouldn't show files that have been deleted since
> ages and tmp files! And, yes, I verified several times that these files are
> no longer in the directory (nor in the dustbin or anything).
I think, that is a bug. When clicking on 'Templates', the window should only contain templates, nothing else. But that it a different problem. Can you please write a separate bug report about that? It is really a bug, because for example I see file 'thumbs.db'.
Comment 15 ribotb 2016-08-03 12:43:57 UTC
I note another annoying 'stuff' in Start Center : templates are not displayed in alphabetical order. It seems that they are displayed in order of the folders which contain them.

Bernard
Comment 16 Regina Henschel 2016-08-04 22:10:22 UTC
*** Bug 101306 has been marked as a duplicate of this bug. ***
Comment 17 Yousuf Philips (jay) (retired) 2016-08-10 18:40:05 UTC
Patch to make only templates show is here.

https://gerrit.libreoffice.org/#/c/27929/

Patch for the template categories is here, but there is a bug in the code and awaits the dev mentor to look over it.

https://gerrit.libreoffice.org/27534
Comment 18 Commit Notification 2016-08-15 06:51:13 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f8f68042597cd38b8dab7413baadb093c4a01a00

tdf#101141 Show only template files in start center and template manager

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Xisco Faulí 2016-09-15 22:51:08 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 20 Thorsten Wagner 2016-10-08 19:59:52 UTC
Bug is not fixed in current master.
Comment 21 QA Administrators 2018-02-05 03:27:42 UTC Comment hidden (obsolete)
Comment 22 Cor Nouws 2018-02-06 13:14:50 UTC
Created attachment 139631 [details]
101141_ ScreenPrintStartCenterTemplates in daily20180203
Comment 23 Cor Nouws 2018-02-06 13:16:14 UTC
fixed in Version: 6.1.0.0.alpha0+
Build ID: c7f74bbab4c666a8b3b865dbd58b3666f1f63052
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-02-03_00:22:13
Locale: nl-NL (nl_NL.UTF-8); Calc: group

thanks Akshay! (comment #18)
Comment 24 Yousuf Philips (jay) (retired) 2018-02-06 22:38:31 UTC
(In reply to Cor Nouws from comment #22)
> Created attachment 139631 [details]
> 101141_ ScreenPrintStartCenterTemplates in daily20180203

This isnt related to this bug.
Comment 25 Cor Nouws 2018-02-08 12:49:17 UTC
(In reply to Yousuf Philips (jay) from comment #24)

> This isnt related to this bug.

Oh, sorry.
Can you please explain what I possibly understand wrong in this issue?
Comment 26 Yousuf Philips (jay) (retired) 2018-02-13 08:05:24 UTC
(In reply to Cor Nouws from comment #25)
> Oh, sorry.
> Can you please explain what I possibly understand wrong in this issue?

The issue is about the template folders/categories that used to appear in the start center after clicking the templates button. This folder/file view was removed from the template manager when it was redesigned and replaced with the search/filter bar, but this bar never made its way into the start center.
Comment 27 ribotb 2018-02-13 09:21:36 UTC
Hi,

In fact, for me, the only small and not annoying problem is that the templates are not displayed in alphabetical order when clicking on the Templates button. But it is very easy to retrieve templates by using the search/filters Bar.

Bernard
Comment 28 Cor Nouws 2018-02-13 15:28:47 UTC
(In reply to Yousuf Philips (jay) from comment #26)

> The issue is about the template folders/categories that used to appear in
> the start center after clicking the templates button. This folder/file view
> was removed from the template manager when it was redesigned and replaced
> with the search/filter bar, but this bar never made its way into the start
> center.

In the Template Manager one can select Applications (Writer, Calc, ..) and Categories (separate folder names)
In the Start Center one can only select Applications.
Correct?

(In reply to ribotb from comment #27)

> In fact, for me, the only small and not annoying problem is that the
> templates are not displayed in alphabetical order when clicking on the
> Templates button. But it is very easy to retrieve templates by using the
> search/filters Bar.

I do not see that bar in the Start Center. Only in the Template Manager dialog. Correct?

(I get somehow confused because the Summary is on the Start Center and the original description on the Template Manager :p )
Comment 29 ribotb 2018-02-13 17:30:07 UTC
(In reply to Cor Nouws from comment #28)

> 
> > In fact, for me, the only small and not annoying problem is that the
> > templates are not displayed in alphabetical order when clicking on the
> > Templates button. But it is very easy to retrieve templates by using the
> > search/filters Bar.
> 
> I do not see that bar in the Start Center. Only in the Template Manager
> dialog. Correct?
> 

Sorry ! I was talking about the drop-down list displayed by the small arrow on the right of the Templates button.

Bernard
Comment 30 Yousuf Philips (jay) (retired) 2018-02-14 15:06:13 UTC
(In reply to Cor Nouws from comment #28)
> In the Template Manager one can select Applications (Writer, Calc, ..) and
> Categories (separate folder names)
> In the Start Center one can only select Applications.
> Correct?

Yes that is what this bug is about, you cant filder by categories/folders.
Comment 31 ribotb 2018-02-14 15:32:35 UTC
(In reply to Cor Nouws from comment #28)
> In the Template Manager one can select Applications (Writer, Calc, ..) and
> Categories (separate folder names)
> In the Start Center one can only select Applications.
> Correct?

Yes!
Comment 32 QA Administrators 2019-02-15 03:47:05 UTC Comment hidden (obsolete)
Comment 33 ribotb 2019-02-15 08:10:10 UTC
Hi,
In the Start Center I no longer use the templates button, Now, I first choose the application by using the drop-down list (displayed by the small arrow on the right of the Templates button).
Bernard