Bug 101143 - Online Help for Options - LibreOffice Calc - Formula - Detailed Calculation Settings not linked
Summary: Online Help for Options - LibreOffice Calc - Formula - Detailed Calculation S...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Help-Link
  Show dependency treegraph
 
Reported: 2016-07-27 02:28 UTC by Aron Budea
Modified: 2020-12-20 00:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-07-27 02:28:58 UTC
There is this page: https://help.libreoffice.org/Calc/OpenCL_Options

It seems to be the help page for the dialog accessible this way: Menu Tools - Options - LibreOffice Calc - Formula, and in section Detailed Calculation Settings press Details... button.

However, if I press F1 or Help in the dialog, this useless page comes up instead:
https://help.libreoffice.org/scalc/modules/scalc/ui/formulacalculationoptions/comboConversion?Language=en-US&System=WIN&Version=5.1
(this is for the first combo box, but none of the other UI elements produce useful help)
Comment 1 Aron Budea 2016-08-03 12:31:28 UTC
Note that Tor's commit to bug 101063 removed all OpenCL Options from Calc (the ones in LibreOffice remain), which means the help will have to change in 5.3.
Comment 2 Buovjaga 2016-08-05 18:06:06 UTC
Confirmed the behavior, when offline help is not present. Otherwise the OpenCL options page is displayed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.4
Build ID: 5.2.0-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: f3d26af51588af441f62fb69bb7a5432845226ac
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 5th 2016
Comment 3 Buovjaga 2018-04-13 10:29:39 UTC
Same problem with new online help. Gives https://help.libreoffice.org/6.1/en-US/text/scalc/main0000.html?System=WIN&DbPAR=CALC
Comment 4 sdc.blanco 2020-12-20 00:38:24 UTC
Open Detailed Calculations dialog in Options (Alt-F12)
Press "Help" button
Relevant help page is shown. 

Tested successfully with 6.3.6.2 and 7.2.0.0.alpha0+ -- closing as WFM