Download it now!
Bug 101323 - Style name is not changed in LibreOffice Draw
Summary: Style name is not changed in LibreOffice Draw
Status: RESOLVED DUPLICATE of bug 38225
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 101288 (view as bug list)
Depends on:
Blocks: ImpressDraw-Styles
  Show dependency treegraph
 
Reported: 2016-08-05 15:44 UTC by Nicholas Borisov
Modified: 2018-05-08 11:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Rename of style name not saved to file (11.17 KB, application/vnd.oasis.opendocument.graphics)
2016-11-08 16:58 UTC, Ian Watson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Borisov 2016-08-05 15:44:26 UTC
Hello !

Summary.

I can't change a style name that i created in Draw. Please pay attention (!) what i actually mean. I can save a file and many properties of style such as color, font, arrow styles, transparency and so on. The bug does not appear in Writer and Calc.

Characteristics of my system:

1). Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: ru-RU (ru_RU)
2). Windows 7.
3). CPU Intel Pentium Dual-Core T4400. 

How to reproduce the bug:

1. Create a new connector.
1. Create a new style in Draw for new connector. Give the name for this one (for example "New Connector") and save a file in ".odg" format. 
2. Reload the file. 
3. Change the style name from "New Connector" to "Connector-1". 
4. Save the file. 
5. Reload the file. The style name steal "New Connector".

Bug reproduced by me (LibreOffice 5.2.0.4 on Windows 7) and mr. Hagar Delest AOO 4.1.2 on Xubuntu 16.04.
Comment 1 Regina Henschel 2016-08-05 17:39:17 UTC
It happens not only with a connector, but every custom style. The error happens on save. I see the error already in OOo3.2.1., the version OOo2.4.3 had been OK.

I expect that the style:name attribute is changed or that at least the style:display-name attribute is changed.
Comment 2 Nicholas Borisov 2016-08-05 19:05:10 UTC
I don't understad what do you exactly mean :) What are we going to do now ?
Comment 3 Nicholas Borisov 2016-08-06 11:59:22 UTC
I detected the similar bug in Impress. :(((
Comment 4 Heiko Tietze 2016-08-07 08:30:27 UTC
Using the _toolbar button_ 'New Style' from the sidebar works as expected: the 'create style' dialog is shown and allows to enter the name, which is used and shown correctly afterwards.

Using 'New...' from the _context menu_ shows the full graphics styles dialog. Changes to the name field seems to have no effect. But actually it is saved, somehow, as you can see it in the list of existing styles in the 'create style' dialog.

It's not surprising that Impress is also affected since both share the same code base.

Version: 5.2.0.3
Build ID: 7dbd85f5a18cfeaf6801c594fc43a5edadc2df0c
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: de-DE (en_US.UTF-8)
Comment 5 Heiko Tietze 2016-08-07 08:32:23 UTC
*** Bug 101288 has been marked as a duplicate of this bug. ***
Comment 6 Nicholas Borisov 2016-08-07 11:39:29 UTC
(In reply to Heiko Tietze from comment #4)
> Using the _toolbar button_ 'New Style' from the sidebar works as expected:
> the 'create style' dialog is shown and allows to enter the name, which is
> used and shown correctly afterwards.
> 
> Using 'New...' from the _context menu_ shows the full graphics styles
> dialog. Changes to the name field seems to have no effect. But actually it
> is saved, somehow, as you can see it in the list of existing styles in the
> 'create style' dialog.


Thank you for your answer ! But, i said in the beginning that i can save the style ! 

"I can save a file and many properties of style such as color, font, arrow styles, transparency and so on".
Comment 7 Nicholas Borisov 2016-08-07 11:54:11 UTC
Well, i have to say some words about my user experience relating to the support. I created more then 4 topics and bug reports on these sites: ask.libreoffice.org , forum.openoffice.org, bugs.documentfoundation.org. I am very appreciate for your answers, but it's a hard way to improve the product for ordinary end-users. We need a clear answer and plan to action with deadlines. This is a very important part of quality product.
Comment 8 Heiko Tietze 2016-08-08 08:22:01 UTC
(In reply to Nicholas Borisov from comment #7)
> Well, i have to say some words about my user experience relating to the
> support...

Neither LibreOffice nor The Document Foundation provide _support_ as known from commercial products. We develop an open source product, which means everybody can and should contribute. Keep in mind that most of the people are volunteers, much of the code has a history dating back to star office, and many of the new features are implemented by students that may not continue their participation in the project.

This bug tracker organizes the work but is far away from being a work instruction. Your ticket _may_ be realized if someone cares about the feature. Unclear summary and lengthy reports are counterproductive. I tried to repeat your findings in comment 4. This ticket is a clear bug and has to get fixed. The other one in bug 101326 is not so obvious.
Comment 9 Ian Watson 2016-11-08 16:58:49 UTC
Created attachment 128583 [details]
Rename of style name not saved to file

Test case attached. Edit drawing. Rectangle at top has style 'air'.
In styles menu or side bar, Modify 'air'.
Change Organizer Name to say 'igw'.
Change the line colour to say green.
Hit OK and changes applied.
The rectangle text has change.
Select rectangle. Double click on 'igw' style. It is applied.
Save the document and exit.
Open document.
The Organizer Name has reverted to 'air' - name change lost.
The line colour change has been kept.
System: linux, Fedora 24, libreoffice-draw-5.1.6.2-1.fc24.x86_64.
Comment 10 QA Administrators 2017-11-09 07:43:02 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2018-05-07 20:55:05 UTC
this bug is repro in LO 6.0.3.2
Comment 12 Roman Kuznetsov 2018-05-07 20:57:19 UTC
a dupe for bug 38225?
Comment 13 Xisco Faulí 2018-05-08 11:33:47 UTC
(In reply to kompilainenn from comment #12)
> a dupe for bug 38225?

Yep, it looks like a dupe of bug 38225

*** This bug has been marked as a duplicate of bug 38225 ***