Download it now!
Bug 101326 - Shortcut "repeat" in Draw does not repeat creating an object
Summary: Shortcut "repeat" in Draw does not repeat creating an object
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-05 16:31 UTC by Nicholas Borisov
Modified: 2017-03-01 13:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
- (188.71 KB, application/x-rar)
2016-08-05 16:31 UTC, Nicholas Borisov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Borisov 2016-08-05 16:31:37 UTC
Created attachment 126617 [details]
-

Hello !

Summary.

I can't change 

Characteristics of my system:

1). Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
Locale: ru-RU (ru_RU)
2). Windows 7.
3). CPU Intel Pentium Dual-Core T4400. 

How to reproduce the bug

1. Open LibreOffice Draw.
2. Go tools ---> customise ---> keyboard ---> category: choose edit - function: choose repeat - keys: choose Alt-A (for example)
3. Create 1 object.
4. Use shortcut "ALT-A" for repeating. You won't have any repeating and in other cases.  

Also i want to say that when i opened Draw with english user interface and did't find my selected combinations of shortcuts.
Comment 1 mahfiaz 2016-08-05 17:10:29 UTC
What is the "Repeat" supposed to do?
Comment 2 Nicholas Borisov 2016-08-05 17:12:36 UTC
Repeats last command.
Comment 3 mahfiaz 2016-08-05 19:01:31 UTC
Can you give me an example on how to use it? Some simple steps.
Comment 4 Nicholas Borisov 2016-08-05 19:18:24 UTC
1. Open LibreOffice Draw.
2. Go tools ---> customise ---> keyboard ---> category: choose edit - function: choose repeat - keys: choose "Alt-A" (or any other combination).
3. Create an ellipse.
4. Press "Alt-A" to repeat last command. LibreOffice have to create second ellipse.

You really don't use this method to speed up your productivity ? Please, google it.
Comment 5 Cor Nouws 2016-08-06 00:33:05 UTC
Hi Nicholas,

(In reply to Nicholas Borisov from comment #0)

> 4. Use shortcut "ALT-A" for repeating. You won't have any repeating and in
> other cases.  

The repeat command only repeats a limited set of instructions.
Bug 96228 is to collect issues around this - actions that should be repeated. Not sure if inserting an object should be one..

> Also i want to say that when i opened Draw with english user interface and
> did't find my selected combinations of shortcuts.

I think the customization is language dependent..


I would suggest NotABug since it works as expected?
Comment 6 Nicholas Borisov 2016-08-06 12:07:37 UTC
I tried numerous variations of using this shortcut for different purposes like:
1). inserting an object
2). repeated applying the style for objects

Please pay attention ! This shortcut is working very well in other applications - Writer and Calc. I can apply the same style to many sets of objects such as strings, words, paragraphs, cells in one-action. I don't really understand - for which purpose this function is working in Draw ? Can you give to me some examples ?
Comment 7 Nicholas Borisov 2016-08-06 12:11:22 UTC
In Writer you can print a character (for example "A", "B") and repeat this action by using shortcut "Repeat". I think this are equal actions: creating of character like "A" and graphic object like "ellipse".
Comment 8 Heiko Tietze 2016-08-07 08:11:34 UTC
Even Writer allows not every action to be repeated. In particular, you cannot create multiple shapes/charts, move floating objects by or to a certain position, duplicate line breaks... What works is to set properties of the paragraph style and tables.

Assuming the repetition for shapes cannot be accomplished (it would be relevant for Writer too), what else makes sense in case of Draw?

Do you know the Edit > Duplicate function (Shift+F3)?
Comment 9 Nicholas Borisov 2016-08-07 11:35:05 UTC
Yes, i know about this fucntion. I repeat my question. 

For which purpose this function is working in Draw ? Can you give to me some practical examples ?
Comment 10 Heiko Tietze 2016-08-08 08:27:11 UTC
(In reply to Nicholas Borisov from comment #9)
> Yes, i know about this fucntion. I repeat my question. 
> 
> For which purpose this function is working in Draw ? Can you give to me some
> practical examples ?

What do you expect?`

(In reply to Heiko Tietze from comment #8)
> Assuming the repetition for shapes cannot be accomplished (it would be
> relevant for Writer too), what else makes sense in case of Draw?

Tendentially we should consider to remove the repeat function completely from Draw and Impress.
Comment 11 QA Administrators 2017-03-01 10:41:31 UTC Comment hidden (obsolete)
Comment 12 Heiko Tietze 2017-03-01 13:03:58 UTC
The issue is not a bug but an enhancement request. Please file separate tickets for those functions that you expect to be repeated. 

-> WONTFIX