Bug Hunting Session
Bug 101340 - draw:opacity not imported correctly with slides
Summary: draw:opacity not imported correctly with slides
Status: RESOLVED DUPLICATE of bug 107584
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ODF-import
  Show dependency treegraph
 
Reported: 2016-08-05 18:57 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-06-25 09:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample (24.59 KB, application/vnd.oasis.opendocument.presentation)
2016-08-05 18:57 UTC, Yousuf Philips (jay) (retired)
Details
version with gradient (17.07 KB, application/vnd.sun.xml.impress)
2016-08-05 23:46 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-08-05 18:57:24 UTC
Created attachment 126619 [details]
sample

Steps:
1) Open attached document
2) Notice that background color is set to black but slide background is white, likely as it setting the transparency to 

The XML : <style:drawing-page-properties draw:fill="solid" draw:fill-color="#000000" draw:opacity="50%" ... />

ODF spec - http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#property-draw_opacity

Version: 5.3.0.0.alpha0+
Build ID: 8da4ba9be2d2deb8990f40fa0cc5d6b16d525c72
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-03_23:43:46
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Regina Henschel 2016-08-05 23:46:57 UTC
Created attachment 126624 [details]
version with gradient

I have tried using an element draw:opacity, which means using a transparency gradient. But that works neither. I have tried it in ODF1.1 too, so that PowerPoint 2010 can open it, I tried Calligra too. Neither of them can handle transparency.
Comment 2 Regina Henschel 2016-08-05 23:48:10 UTC
"sample" is not valid ODF, but that is irrelevant here.
Comment 3 Katarina Behrens (CIB) 2017-06-25 09:46:19 UTC
The duplicate report is slightly different (UI setting up the page transparency has no effect), but the underlying cause is the same: the transparency/opacity bit is neither exported nor imported

To see the effect of the fix also on this sample, you have to turn displaying slide background on, 'cause it's off in this document

*** This bug has been marked as a duplicate of bug 107584 ***