Bug 101356 - Table of contents not reflect the Style chapter format
Summary: Table of contents not reflect the Style chapter format
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2016-08-06 15:57 UTC by ThierryT
Modified: 2016-10-20 08:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ThierryT 2016-08-06 15:57:07 UTC
My version software:
Version: 5.1.5.2 (x64)
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
Threads CPU : 4; Version de l'OS :Windows 6.29; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: group

I've defined personal Style chapters in my document.
For each Style chapter, I've defined :
- Their numbering with 'Tools> Chapter numbering', under option Character after, I put " -" (space and dash)
- With 'Tab>Position', I choose "Space" option for 'Numbering followed by'

When I affect the Style chapters in my text, I have no problem : the space character is inserted after the chapter numbers.
Example :
1 Title1
1.1 Sub-Title1
2 Title2

When I want to generate the table contents, I always have :
1Title1
1.1Sub-Title1
2Title2

That means, the space we define under "Tab/Position" is never included in the table contents.
Comment 1 Regina Henschel 2016-08-06 18:41:08 UTC
The format of a line in the index is independent from the format of the heading. That is intended. For example, making an index as requested by DIN, the text lines in the index need to be left aligned to a common position. That is only possible using a tab. But you surely do not want such tab in the heading itself.

Therefore you can design the form of a line in the index directly in the dialog tab 'Entries' in the index edit dialog. There you can add a space or a tab as you need it. If you need help doing this, use a channel listed on https://www.libreoffice.org/get-help/community-support/
Comment 2 ThierryT 2016-08-07 09:35:03 UTC
Thanks for your reply and I understand perfectly your meaning.

But if you want to have the same definitions in the Text and in the Index, you have to define them in two different windows => you have to make the job twice with some possible troubles.

Suggestion : By default, if nothing is defined in the dialog tab 'Entries' in the index edit dialog, we use the definition in the Tools> Chapter numbering dialog in the Table of contents.

What do you think about this suggestion ?
Comment 3 ThierryT 2016-08-07 10:07:28 UTC Comment hidden (no-value)
Comment 4 Yousuf Philips (jay) (retired) 2016-10-19 21:21:19 UTC
@Heiko, @Stuart, @Cor: The bug reporter disagrees with regina closing this bug as NOTABUG, so can you give your input and close if need be.
Comment 5 Cor Nouws 2016-10-20 08:05:40 UTC
(In reply to Yousuf Philips (jay) from comment #4)
> @Heiko, @Stuart, @Cor: The bug reporter disagrees with regina closing this
> bug as NOTABUG, so can you give your input and close if need be.

Yes, and also related to bug 44282.

@Thierry: I think when that is fixed, you'll be a bit more happy in default cases?