Bug 101381 - KDE integration / Quickstart not working
Summary: KDE integration / Quickstart not working
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Quickstarter
  Show dependency treegraph
Reported: 2016-08-08 09:43 UTC by u.fuchs
Modified: 2017-08-21 09:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description u.fuchs 2016-08-08 09:43:54 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36
Build Identifier: LibreOffice

I use the Document Foundation LibreOffice Version 5.2 / kubuntu 14:04, 32-bit. In version 5.0, the KDE integration and quickstart worked perfectly. In 5.2 both don't work any more. The menus do not look nice and the quickstart does not work. This is a regression. After uninstalling the package libobasis5.2-kde-integration menus look appealing again and quickstart works. However, the quickstart menu is missing all the icons. These appear only after installing the package libreoffice-common + dependencies.

Reproducible: Always

Steps to Reproduce:
1.Try to activate quickstart (tools - options - memory - enable systray quickstarter)
2.Uninstall libobasis5.2-kde-integration
3.Try again to activate quickstart
Actual Results:  
Quickstart without icons in menu, but working

Expected Results:  
kde integration should work as in version 5.0.

[Information automatically included from LibreOffice]
Locale: de
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: no

Reset User Profile?No
Comment 1 Buovjaga 2016-08-10 18:29:15 UTC
Note that Debian removed quickstart and has not yet put it back: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=825642
Comment 2 u.fuchs 2016-08-11 08:35:56 UTC
Note that I intentionally only use the original version of the Document Foundation and not Ubuntus or Debians, which I completely uninstalled. And here uninstalling libobasis5.2-kde-integration leads to a good look of the menus. Simultaneously quickstart works again. The missing icons in /usr/share/icons can be inserted most easily by installing the Ubuntu package libreoffice-common. This can also be immediately uninstalled including its dependencies, if care is taken that the installed icons of the package will not be deleted. It is therefore an error in the packet libobasis5.2-kde-integration, or in qickstart where maybe wrong paths to the icons are present. In version 5.0 (also Document Foundation) it worked perfectly without the "adjustments" described above. I call that a regression.
Comment 3 Jan-Peter Rühmann 2016-12-23 16:18:13 UTC

In the new Version Quickstart won´t work at all.
until now it helped to remove the KDE-Integration. That is not working anymore.

When will there a Version that works again it is now at least since 2 Years there.
But nothing happens.

I think a new UI is a fine thing to have But before that such small thinks such as Quickstart have to work.

Comment 4 Rene Engelhard 2017-08-21 09:11:21 UTC
I wonder why are people expecting that the *GTK2* using Quickstarter works in KDE anyways? It even barely works in GNOME(3). (The "systray" is hidden and needs to be epanded per default (> on lower end of the desktop)

There never was a *KDE* Quickstarter.
Comment 5 Buovjaga 2017-08-21 09:54:47 UTC
Now Quickstarter was removed: https://wiki.documentfoundation.org/ReleaseNotes/6.0#Linux