Bug 101390 - Enable .uno:ArrowsToolbox and its entries in Writer and Calc
Summary: Enable .uno:ArrowsToolbox and its entries in Writer and Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Gülşah Köse
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords: needsDevEval, topicUI
: 90651 (view as bug list)
Depends on:
Blocks: Writer-Toolbars Unify-Across-Apps
  Show dependency treegraph
 
Reported: 2016-08-08 14:39 UTC by Yousuf Philips (jay)
Modified: 2016-10-24 19:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2016-08-08 14:39:55 UTC
Presently the lines and arrows split button (.uno:ArrowsToolbox) and its various underlying buttons (.uno:LineArrowEnd, .uno:LineCircleArrow, .uno:LineSquareArrow, .uno:LineArrows, .uno:LineArrowStart, .uno:LineArrowCircle, .uno:LineArrowSquare, .uno:MeasureLine, .uno:Line_Diagonal) are exclusive to impress and draw and it would be useful for it to be also available in writer and calc.
Comment 1 Heiko Tietze 2016-08-08 15:17:08 UTC
Sounds like an EASYHACK. But I'm afraid of Jan's rebuke. :)
Comment 2 Commit Notification 2016-09-07 18:34:33 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37a3fc1ca2a08e41dcf39946d891e7e315106d64

tdf#101390 Add Arrows toolbox functions on writer drawingbar.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Yousuf Philips (jay) 2016-09-08 16:21:41 UTC
@Gulsah: You pulled yourself as the assignee, so do this mean you dont have time to implement the calc part?
Comment 4 Gülşah Köse 2016-09-09 09:07:13 UTC
Yousuf: We are about to enter a public holiday. I may not access the internet for a week. i've pulled mysef assignee, because if anyone want to implement that part during this time i don't want to hinder her/him. When I get back I'll close this bug.
Comment 5 Commit Notification 2016-09-25 07:01:14 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7b8832ff972a4e9f3e03fd7d96882b2a78c03b3e

tdf#101390 Add Arrows toolbox functions on calc drawingbar.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Maxim Monastirsky 2016-09-25 07:09:30 UTC
Hi Gülşah,

Thanks again for your work on this!

Is it possible to also add .uno:Line_Diagonal to the dropdown?
Comment 7 Gülşah Köse 2016-09-26 09:24:50 UTC
Hi Maxim,

Thanks for review. I'll add .uno:Line_Diagonal and .uno:MeasureLine too.
Comment 8 Commit Notification 2016-10-10 23:09:54 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6

tdf#101390 Add "Dimesion Line" command to the writer arrowsbox.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2016-10-13 13:12:34 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=042a7fc229c44fcb7a0c009a1b7f5d34913f8c12

tdf#101390 Add "Dimesion Line" command to the calc arrowsbox.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-10-13 17:31:51 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3f95221b83f2302778e315330ff8ccf2998a397

tdf#101390 Add "Diagonal Line" command to the writer arrowsbar.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2016-10-13 17:38:54 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=19dc5d725791388f1b7b17af2e48b0abdf8990bd

tdf#101390 Add "Diagonal Line" command to the calc arrowsbar.

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Maxim Monastirsky 2016-10-24 19:32:52 UTC
*** Bug 90651 has been marked as a duplicate of this bug. ***