Bug Hunting Session
Bug 101402 - Chart sidebar properties deck no longer functional/visible
Summary: Chart sidebar properties deck no longer functional/visible
Status: RESOLVED DUPLICATE of bug 100180
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Chart-Sidebar
  Show dependency treegraph
 
Reported: 2016-08-09 05:57 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-11-03 14:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast (2.01 MB, video/webm)
2016-08-09 08:24 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2016-08-09 05:57:38 UTC
Steps:
1) one writer
2) insert a chart
3) click on chart to initialize chart properties sidebar and it appears for a second and then disappears

Regression as this works in 5.1.

Version: 5.3.0.0.alpha0+
Build ID: 07966a9999b0b3f27e1adeea1f4c97b3ba2944fa
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-05_23:22:09
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 mahfiaz 2016-08-09 07:05:39 UTC
I tried to reproduce but failed.

Both behave the same (sidebar is open before).
1) Open Writer
2) Insert Chart (chart itself is editable)
3) See how the sidebar shows whatever options it has for the large element itself
4) Click outside of the chart to stop editing it, chart still active
5) Now sidebar is empty (is this the bug?)
5) Click one more time outside to unselect chart
6) Sidebar shows normal text stuff
7) Click on chart
8) Sidebar shows the same stuff as in 3)
Comment 2 Susobhan Ghosh 2016-08-09 07:38:58 UTC
Cannot reproduce. Tested on 5.1.4.2, 5.2.0.4 and 5.3.0.0.alpha0+

The sidebar gets activated as it should when a data set (or the bar in the chart) is clicked. Works as expected.
Comment 3 Yousuf Philips (jay) (retired) 2016-08-09 08:24:06 UTC
Created attachment 126685 [details]
screencast

Hopefully the screencast will make it easier. I tested it on 5.2 daily and 5.3 daily and both are broken.
Comment 4 mahfiaz 2016-08-09 10:24:56 UTC
Oh, you are unhappy with it showing object wrapping options. Unless you select something in the chart, what else is it supposed to show you?
Comment 5 Yousuf Philips (jay) (retired) 2016-08-09 10:51:21 UTC
(In reply to mahfiaz from comment #4)
> Oh, you are unhappy with it showing object wrapping options. Unless you
> select something in the chart, what else is it supposed to show you?

No the showing of the object wrapping options is something that presently doesnt have a fix, but once you get into chart edit mode and you click on a chart element, then the chart sidebar appears. For example click on a data series and the chart sidebar will appear for a second before reverting back to showing the area, wrap, and position & size content panels from non-chart edit mode.
Comment 6 mahfiaz 2016-08-10 10:42:12 UTC
(In reply to Yousuf (Jay) Philips from comment #5)

This is not what happens on my computer. Although there is some flickering, especially when I change the width of the sidebar. Something is fishy with that layout.
Comment 7 Buovjaga 2016-08-12 18:29:00 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> For example click on a data
> series and the chart sidebar will appear for a second before reverting back
> to showing the area, wrap, and position & size content panels from non-chart
> edit mode.

The first time I clicked on an element it did not show the options. Then I clicked on another element and it showed them.
I'm setting this baby to NEW.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: f2d09e621757fb5f394998afecba399b638f2428
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on August 12th 2016
Comment 9 Buovjaga 2016-10-12 04:30:00 UTC
Raising priority, as I realized it is massively broken, when I tried triaging a bug.
Comment 10 Katarina Behrens (CIB) 2016-10-13 09:19:21 UTC
Hm, so, is it possible that some1 finds the exact offending commit?

bug#100180, a likely duplicate suspect, claims it is this one: 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=aa0f47aa65693a9763ac0ebeed85c09ac2076431

but even after reverting, the chart sidebar is still locked up for me
Comment 11 Katarina Behrens (CIB) 2016-10-18 08:03:48 UTC
And the same holds here - a duplicate suspect bug 100180 has a fix. If some1 could please test whether it fixes also this issue (b/c I can't repro it in its entirety), and then close as duplicate, fixed respectively. Thanks
Comment 12 Buovjaga 2016-10-18 13:38:32 UTC
(In reply to Katarina Behrens (CIB) from comment #11)
> And the same holds here - a duplicate suspect bug 100180 has a fix. If some1
> could please test whether it fixes also this issue (b/c I can't repro it in
> its entirety), and then close as duplicate, fixed respectively. Thanks

Ok, now it seems to be showing the element properties the first time I click.

There is still some flakiness: if I check Title and Subtitle (or X/Y axis title), unchecking them won't remove them. This seems like an unrelated issue, though.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 3498ed37527b7af795f00dc6a55c11e65a313186
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 18th 2016
Comment 13 Markus Mohrhard 2016-10-26 16:54:53 UTC
I suppose at some point I need to properly add the chart sidebar. Currently this is done through an hack by overwriting the sidebar of the current window. That sadly does not work well and seems to be fragile.
Comment 14 Xisco Faulí 2016-11-03 13:08:33 UTC
Hello,
Which is the current status of this bug in master? Can it be closed now? if not, does the description need to be updated?
Comment 15 Buovjaga 2016-11-03 14:56:56 UTC
Let's close as dupe.

*** This bug has been marked as a duplicate of bug 100180 ***