Download it now!
Bug 101413 - FILEOPEN: Missing checkboxes on DOCX import
Summary: FILEOPEN: Missing checkboxes on DOCX import
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:docx, regression
Depends on:
Blocks:
 
Reported: 2016-08-09 12:46 UTC by Johnny_M
Modified: 2017-08-28 18:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX file displaying the issue (79.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-08-09 12:46 UTC, Johnny_M
Details
Same file saved as DOC by Word 2003 (no issue) (115.50 KB, application/msword)
2016-08-09 12:51 UTC, Johnny_M
Details
Expected result (no issue) as PDF file (396.35 KB, application/.pdf)
2016-08-09 12:55 UTC, Johnny_M
Details
Result in LO 3.3.0, exported to PDF (no issue, but file strongly messed up) (92.12 KB, application/.pdf)
2016-08-09 12:57 UTC, Johnny_M
Details
Result in LO 3.6.4, exported to PDF (no issue, but file displayed not quite correctly (104.20 KB, application/.pdf)
2016-08-09 13:00 UTC, Johnny_M
Details
Result in LO 4.0.4, exported to PDF (issue present, document display is close to the current versions) (104.05 KB, application/.pdf)
2016-08-09 13:08 UTC, Johnny_M
Details
Result in LO 5.2.0, exported to PDF (issue present, current LO version) (99.25 KB, application/.pdf)
2016-08-09 13:09 UTC, Johnny_M
Details
console logs (28.70 KB, text/plain)
2016-08-09 20:20 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny_M 2016-08-09 12:46:24 UTC
Created attachment 126692 [details]
DOCX file displaying the issue

When the attached DOCX file (created with Word 2010, according to document properties) gets opened in LO, there is the following issue (compare to the correct document PDF):

The top three checkboxes (next to "Antrag auf") are missing.


Note: There are also following bugs, but those are not part of this report:
- The end note ("Hinweise") is moved to an additional page (this is the bug 36021, with a workaround available there)
- The automatic page break occurs one line earlier (this is a rather minor text flow issue)


The file is displayed correctly by Word 2003 with the DOCX compatibility pack by Microsoft. Also, if the file is then saved to a DOC file by the Word 2003, the issue does not occur in that DOC file opened by LO.


Tested on:
- Linux Mint 17.1, 64 bit:
Version: 5.1.5.2
Build ID: 1:5.1.5~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: de-DE (en_GB.UTF-8); Calc: group

- Windows Vista, 32 bit:
Version: 5.2.0.4
Build-ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU-Threads: 2; BS-Version: Windows 6.0; UI-Render: Standard;
Gebietsschema: de-DE (de_DE)


On earlier LO versions (*.paf.exe portable versions on 32-big Windows Vista):
- 3.3.0: Issue does not occur (i.e. those checkboxes are present), although the whole document is strongly messed up.
- 3.5.3.1, 3.6.4: Issue does not occur, although the whole document is displayed not quite correctly.
- 4.0.4, 5.0.5: Issue DOES occur, while the document display is close to the current versions.

So that this seems to be a regression in LO 4.0.
Comment 1 Johnny_M 2016-08-09 12:51:03 UTC
Created attachment 126693 [details]
Same file saved as DOC by Word 2003 (no issue)

This is the DOCX file opened with Word 2003 with DOCX compatibility pack and stored as DOC - the issue does not occur when opened in current LO.
Comment 2 Johnny_M 2016-08-09 12:55:45 UTC
Created attachment 126694 [details]
Expected result (no issue) as PDF file

This shows the three checkboxes at the top of the document, missing in the DOCX file. (This PDF was created by the same organization as the DOCX, seemingly also using Word 2010.)
Comment 3 Johnny_M 2016-08-09 12:57:36 UTC
Created attachment 126695 [details]
Result in LO 3.3.0, exported to PDF (no issue, but file strongly messed up)
Comment 4 Johnny_M 2016-08-09 13:00:07 UTC
Created attachment 126696 [details]
Result in LO 3.6.4, exported to PDF (no issue, but file displayed not quite correctly
Comment 5 Johnny_M 2016-08-09 13:08:21 UTC
Created attachment 126697 [details]
Result in LO 4.0.4, exported to PDF (issue present, document display is close to the current versions)
Comment 6 Johnny_M 2016-08-09 13:09:52 UTC
Created attachment 126698 [details]
Result in LO 5.2.0, exported to PDF (issue present, current LO version)
Comment 7 Julien Nabet 2016-08-09 20:20:43 UTC
Created attachment 126704 [details]
console logs

On pc Debian x86-64 with master sources updated today, I could reproduce this.

I attached console log (I use enable-dbgutil)
Comment 8 Xisco Faulí 2016-09-12 12:44:14 UTC
Adding keyword 'bibisectRequest'.
Comment 9 Telesto 2016-11-27 10:08:40 UTC
No repro with:
Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 10 Xisco Faulí 2016-11-27 10:43:59 UTC
I can no longer reproduce it in

Version: 5.3.0.0.alpha1+
Build ID: 4ebf1ea7cb66fc3e6b94cd38dd233aaead69f3d5
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

thus, closing this as RESOLVED WORKSFORME