Bug 101421 - LibreOffice Calc crashes when changing AutoFilter to show *all* entries
Summary: LibreOffice Calc crashes when changing AutoFilter to show *all* entries
Status: RESOLVED DUPLICATE of bug 101165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-10 07:56 UTC by a07cd040897db54e103c
Modified: 2016-08-10 11:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A demo file with autofilter set (9.56 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-08-10 07:56 UTC, a07cd040897db54e103c
Details
A screenshot showing autofilter settings and the checkbox in question (11.30 KB, image/png)
2016-08-10 07:59 UTC, a07cd040897db54e103c
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a07cd040897db54e103c 2016-08-10 07:56:49 UTC
Created attachment 126711 [details]
A demo file with autofilter set

If you have a document that has an AutoFilter set to show only a subset of all rows Calc crashes if you try to reset the AutoFilter to show *all* rows again. What values exactly are filtered by does not matter it only matters that you want to change the filter from any filtered subset to all data.

This seems only to happen with columns that are formattet as DATE.

Windows Server 2k8 R2 x64; LO v5.1.5.2 (x64)
Comment 1 a07cd040897db54e103c 2016-08-10 07:59:20 UTC
Created attachment 126712 [details]
A screenshot showing autofilter settings and the checkbox in question
Comment 2 a07cd040897db54e103c 2016-08-10 08:02:50 UTC
The lateset version we used was 5.0.6.3 and there the problem did not exist.
Comment 3 abma 2016-08-10 09:44:50 UTC
It doesn't crash with LO 5.1.4 x64 on windows.

LO 5.1.5 x32 on windows crashes for me, too.
Comment 4 m.a.riosv 2016-08-10 10:02:38 UTC
Reproducible, clicking 'All' in the filter window crash:
Win10x64
Version: 5.1.5.2 (x64)
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: CL

But Not reproducible with:
Version: 5.1.1.3 (x64)
 Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
 CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
 Locale: es-ES (es_ES)
Version: 5.1.4.0.0+
 Build ID: ec1a2322b862468621ce45500d74dac252bf1714
 CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
 TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1,
 Time: 2016-04-28_06:49:38
Locale: es-ES (es_ES)
Version: 5.2.1.0.0+ (x64)
 Build ID: b7d7089392881575f0332bef4d6b1f4ed10537bc
 CPU Threads: 4; OS Version: Windows 6.19; UI Render: GL; 
 TinderBox: Win-x86_64@62-TDF, Branch:libreoffice-5-2, Time: 2016-08-05_20:56:37
 Locale: es-ES (es_ES); Calc: CL
Version: 5.3.0.0.alpha0+
 Build ID: 9dc3356f1499a2b90078be86ca7470eb2e96aba8
 CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
 TinderBox: Win-x86@39, Branch:master, Time: 2016-07-21_23:52:45
 Locale: es-ES (es_ES); Calc: CL
Comment 5 Alex Thurgood 2016-08-10 11:51:09 UTC

*** This bug has been marked as a duplicate of bug 101165 ***