Bug Hunting Session
Bug 101580 - DOC(X): Writer don't handle changes if text was moved
Summary: DOC(X): Writer don't handle changes if text was moved
Status: RESOLVED DUPLICATE of bug 104797
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-08-17 14:11 UTC by opensuse.lietuviu.kalba
Modified: 2018-01-29 10:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Testing DOCX document (14.40 KB, application/x-php)
2016-08-17 14:11 UTC, opensuse.lietuviu.kalba
Details
View in MS Word.pdf (88.75 KB, application/pdf)
2016-08-17 14:12 UTC, opensuse.lietuviu.kalba
Details
View in LO Writer.pdf (24.49 KB, application/pdf)
2016-08-17 14:12 UTC, opensuse.lietuviu.kalba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description opensuse.lietuviu.kalba 2016-08-17 14:11:00 UTC
Created attachment 126876 [details]
Testing DOCX document

In MS Office Word, in tracking changes mode, if I move text, it is displayed by green.
I open such document in LO Writer, I see only inserted space, but not deleted old text.
Comment 1 opensuse.lietuviu.kalba 2016-08-17 14:12:06 UTC
Created attachment 126877 [details]
View in MS Word.pdf
Comment 2 opensuse.lietuviu.kalba 2016-08-17 14:12:40 UTC
Created attachment 126878 [details]
View in LO Writer.pdf
Comment 3 Cor Nouws 2016-08-22 10:15:56 UTC
Hi Mindaugas,

Thanks for your report and the attached file.

I cannot reproduce the problem in Version: 5.3.0.0.alpha0+
Build ID: 989e8bc0d792f0dc5778746fac45de129a22d7ac
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-08-16_01:29:43
Locale: nl-NL (nl_NL.UTF-8); Calc: group

nor with your file, nor with a new file.

What is your OS please?
Can you test with a clean user profile?
  https://wiki.documentfoundation.org/UserProfile

Ciao - Cor
Comment 4 opensuse.lietuviu.kalba 2016-08-23 11:33:17 UTC
I moved all /home/<USER>/.config/libreoffice/4 directory

I still can reproduce in
Versija: 5.2.1.1
Darinio identifikatorius: 2d75cf29e6d05e44c404f0547047f1da6563d380
Procesoriaus gijos: 4; Operacinės sistemos versija: Linux 3.16; Sąsajos pateikimas: numatytasis; 
Lokalė: lt-LT (lt_LT.UTF-8); Calc: group

I moved again all /home/<USER>/.config/libreoffice/4 directory

I can reproduce also in
Versija: 5.1.5.2
Darinio identifikatorius: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
Procesoriaus gijos: 4; Operacinės sistemos versija: Linux 3.16; Sąsajos pateikimas: numatytasis; 
Lokalė: lt-LT (lt_LT.UTF-8); Calc: group
Comment 5 Buovjaga 2016-09-20 19:33:50 UTC
(In reply to Mindaugas Baranauskas from comment #2)
> Created attachment 126878 [details]
> View in LO Writer.pdf

I confirm it looks like this in 5.3 and also older versions.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 5c8ad526447934a5eae94fa5f40584083a874d9f
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 19th 2016

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 6 QA Administrators 2017-12-11 08:54:39 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2017-12-28 19:12:41 UTC
works OK in Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-12-26_23:09:36
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded


Dragging content makes changes tracked.
Comment 8 Timur 2017-12-29 17:04:17 UTC
I don't see opening DOCX works, same attachment 126877 [details] in MS Word and attachment 126878 [details] in LO Writer.
I'd say a duplicate of Bug 114305.
This one is older but the other one is clear.

*** This bug has been marked as a duplicate of bug 114305 ***
Comment 9 Buovjaga 2018-01-29 10:36:24 UTC

*** This bug has been marked as a duplicate of bug 104797 ***