Bug 101678 - PPTX imported table renders wrong as nested table in table
Summary: PPTX imported table renders wrong as nested table in table
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2016-08-23 07:42 UTC by Christian
Modified: 2018-11-17 14:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PPTX testcase with table (48.71 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-08-23 07:42 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2016-08-23 07:42:07 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build Identifier: 5.2.0.4 Build ID: 066b007f5ebcc236395c7d282ba488bca6720265 

When the provided PPTX file is opened with LO several table cells have tables itself as content. 
This is not the case in PowerPoint. See the screenshot of the same table next to it in the testcase.

Reproducible: Always

Steps to Reproduce:
1.open the testcase
2. wtach the only single slide in edit mode
3.


Expected Results:  
compare the screenshot on the right




Reset User Profile?No
Comment 1 Christian 2016-08-23 07:42:52 UTC
Created attachment 126982 [details]
PPTX testcase with table
Comment 2 Johnny_M 2016-09-17 22:39:11 UTC
Confirmed with:
- 64-bit Linux Mint 17.1:
Version: 5.1.5.2
Build ID: 1:5.1.5~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: de-DE (en_GB.UTF-8); Calc: group

- 32-bit Windows Vista:
Version: 5.2.1.2
Build-ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU-Threads: 2; BS-Version: Windows 6.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

- 32-bit Window Vista (as portable release):
LO 3.5.3.2


With LO 3.3.0 (portable release on Vista): The left (issue displaying) table is not shown at all.

MS Office 2003 shows the table correctly (after automatic conversion to .ppt).
Comment 3 Xisco Faulí 2017-09-29 08:52:49 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2017-11-08 15:41:21 UTC
Still reproducible in

Version: 6.0.0.0.alpha1+
Build ID: 38a8157d9447134913d88c6c373d99a7aa472857
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 5 QA Administrators 2018-11-09 03:59:33 UTC Comment hidden (obsolete)
Comment 6 Johnny_M 2018-11-10 21:25:21 UTC
Still reproducible in (on Ubuntu Mate 18.04.1 liveUSB):

Version: 6.2.0.0.alpha1+
Build ID: bf4fc97131147d25b18d088023262c977f0b2787
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-10_01:52:15
Locale: en-US (C.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Christian 2018-11-17 14:50:56 UTC
Still reproducible with LO Version: 6.1.0.2
on CentOS 7