Bug Hunting Session
Bug 101759 - Opening files via FTP fails: can not resolve host
Summary: Opening files via FTP fails: can not resolve host
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2016-08-27 23:16 UTC by Sanchke Dellowar
Modified: 2018-05-30 16:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sanchke Dellowar 2016-08-27 23:16:46 UTC
Linux Mint 18 (Cinnamon).
Libreoffice 5.2.0.4

I have .odt & .otg on a local server who's address is 192.168.1.8
When attempting to open them (via Nemo), Libreoffice asks for credentials, I fill them in. Press 'OK', then I get a dialog box saying:

"The host name 192.168.1.8 could not be resolved." - And that's that no file opened.

Going into more detail, I get the same error attempting to open files using FTP via:
 - Bash (`libreoffice5.2 ftp://username@192.168.1.8/path.odg`)
 - Libreoffice's Open Remote File Dialog
 - Libreoffice's Open File Dialog
 - Nemo (File Browser)
So out of all the ways to get to the file, all of them fail the same way.

Now here's the kicker: if I use SFTP or SSH, it works perfectly fine. So this is obviously a FTP-only issue.

Also allow me to add that this same FTP connection works fine with all other services requiring it: so it is certainly not an issue with the server or client computers, it is only libreoffice having issues with it.


Thank you very much!
    -Sanchke


PS: Before anyone get's on their high horse about why not to use FTP: I am using FTP because I need all the speed I can get, for I am dealing with large files. ;)
Comment 1 V Stuart Foote 2016-08-27 23:27:09 UTC
Duplicate of bug 72460?
Comment 2 Sanchke Dellowar 2016-08-27 23:51:07 UTC
(In reply to V Stuart Foote from comment #1)
> Duplicate of bug 72460?

No.

The author of bug 72460 managed to get his working via the 'open file' -> '...' dialog. I am not able to do that.
Comment 3 Aron Budea 2016-08-28 00:40:53 UTC
Since the bug hasn't been confirmed independently, let's leave status as UNCONFIRMED.
Comment 4 Aron Budea 2016-08-28 16:24:10 UTC
I tried accessing files via FTP (anonymous user) over home network, and had no problem. Used LibreOffice 5.2.0.4 on Ubuntu 14.04.
Comment 5 Sanchke Dellowar 2016-08-28 18:33:40 UTC
(In reply to Aron Budea from comment #4)
> I tried accessing files via FTP (anonymous user) over home network, and had
> no problem. Used LibreOffice 5.2.0.4 on Ubuntu 14.04.

Interesting. Any chance you could test without using anonymous user? And are you entering IP or domain as a host?
Comment 6 Aron Budea 2016-08-29 00:29:17 UTC
(In reply to Sanchke Dellowar from comment #5)
> Interesting. Any chance you could test without using anonymous user? And are
> you entering IP or domain as a host?

Sure, I just tried with a normal user, with same results. I've been using IP address, and tried three of the four methods you listed (except the last one).

So either the message is completely bogus (for example it can't connect to the FTP server for some reason, but gives an unrelated error message), or the issue is indeed that it's trying to resolve an IPv4 address as host name... like, maybe LibreOffice somehow gets the idea the system is only using IPv6 addresses, so it tries to resolve an IPv4 one as host name?
I don't know if that can actually happen, it's just an example of what my thought process would be (there's also the complication that then it likely wouldn't work fine with other services).
Comment 7 Xisco Faulí 2017-10-31 19:15:22 UTC
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 8 QA Administrators 2018-05-02 15:47:43 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2018-05-30 16:49:00 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20180530