Bug 101818 - UI: Add paste options pop-up after using Ctrl+V shortcut
Summary: UI: Add paste options pop-up after using Ctrl+V shortcut
Status: RESOLVED DUPLICATE of bug 89378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: Paste-Special
  Show dependency treegraph
 
Reported: 2016-08-31 14:16 UTC by Marco A.G.Pinto
Modified: 2018-01-12 09:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of sketch (16.08 KB, image/png)
2016-08-31 14:16 UTC, Marco A.G.Pinto
Details
The LibreOffice Paste Special dialog GUI (6.63 KB, image/png)
2016-08-31 22:46 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2016-08-31 14:16:07 UTC
Created attachment 127096 [details]
screenshot of sketch

Hello!

Here is a sketch of how it should look like based on Microsoft's.

Something like this should appear when one does PASTE into a document.
Comment 1 V Stuart Foote 2016-08-31 22:46:00 UTC
Created attachment 127104 [details]
The LibreOffice Paste Special dialog GUI

Because our existing Paste Special dialog is not "graphical" enough?

No, this is silly everything does not have to have Icons.
Comment 2 Marco A.G.Pinto 2016-09-01 05:22:30 UTC
(In reply to V Stuart Foote from comment #1)
> Created attachment 127104 [details]
> The LibreOffice Paste Special dialog GUI
> 
> Because our existing Paste Special dialog is not "graphical" enough?
> 
> No, this is silly everything does not have to have Icons.

How do I make the dialogue to appear?

I pressed CTR+V (paste) and it didn't appear.
Comment 3 Marco A.G.Pinto 2016-09-01 05:23:43 UTC
(In reply to V Stuart Foote from comment #1)
> Created attachment 127104 [details]
> The LibreOffice Paste Special dialog GUI
> 
> Because our existing Paste Special dialog is not "graphical" enough?
> 
> No, this is silly everything does not have to have Icons.

Ahhh... with a right-click... but why not CTR+V as well?
Comment 4 Adolfo Jayme 2016-09-01 07:51:36 UTC
Marco, the Paste Special dialog has its own keyboard shortcut: Ctrl + Shift + V.
Comment 5 Aron Budea 2016-09-01 22:51:31 UTC
(In reply to V Stuart Foote from comment #1)
> No, this is silly everything does not have to have Icons.

While that's true in general, in this case I don't agree.
LibreOffice's Paste Special dialog is very powerful, but the many choices are equally confusing.
Yesterday I tried copying cells from Calc into Writer, these were my options:
-calc8
-GDI metafile
-Bitmap
-HTML (Hypertext Markup Language)
-DDE Link
-Unformatted text
-Formatted text (RTF)

If you're a novice user who tries to put some data inside a table from Calc into Writer, what do you do?

While I agree that having the option of several choices is good (though I'm not convinced all of them make a lot of sense in this particular example), having a basic dialog with the most meaningful choices that are easy to interpret would be extremely helpful, with the option to switch to the current, "expert" dialog.

Additionally, I believe LibreOffice's choices don't have the "Merge" option that is in the suggestion, so the question whether or not that could be useful to implement is still open.
Comment 6 Cor Nouws 2016-09-03 10:04:15 UTC
(In reply to Aron Budea from comment #5)

> [...]
> If you're a novice user who tries to put some data inside a table from Calc
> into Writer, what do you do?

Try options and learn a lot? I appreciated that :)

> While I agree that having the option of several choices is good (though I'm
> not convinced all of them make a lot of sense in this particular example),
> having a basic dialog with the most meaningful choices that are easy to
> interpret would be extremely helpful, with the option to switch to the
> current, "expert" dialog.

Then the Calc version of Paste Special could be a direction to look at?

> Additionally, I believe LibreOffice's choices don't have the "Merge" option
> that is in the suggestion, so the question whether or not that could be
> useful to implement is still open.

I can imagine scenario's where Keep source and Merge easily brake proper use of styles, but that's a different discussion all together.
Comment 7 Amr Ibrahim 2017-06-12 11:13:00 UTC

*** This bug has been marked as a duplicate of bug 89453 ***
Comment 8 Timur 2017-06-14 07:56:29 UTC
Let's reconsider this. 
First Stuart marked as WontFix because Paste Special dialog already exists. BUT, request was: 
"Something like this should appear when one does PASTE into a document." So Paste Special dialog is not that, it doesn't appear. 
Then Amr marked as duplicate of bug 89453 which is also another issue, to improve a wording, not a paste issue. 
So I set back to Unconfirmed but I'm in favor of confirming to New. Because it's a common and important mistake to just paste (with format) and average user unfortunately just does that.
Comment 9 Cor Nouws 2017-06-14 13:11:51 UTC
(In reply to Timur from comment #8)

> So I set back to Unconfirmed but I'm in favor of confirming to New. Because
> it's a common and important mistake to just paste (with format) and average
> user unfortunately just does that.

then I know people that look away in confusion when such a popup appears ;) but ..
(maybe in the end separate issues for Writer, Calc, Impress are needed.)
Comment 10 V Stuart Foote 2017-06-14 13:39:53 UTC
(In reply to Timur from comment #8)
> Let's reconsider this. 
> First Stuart marked as WontFix because Paste Special dialog already exists.
> BUT, request was: 
> "Something like this should appear when one does PASTE into a document." So
> Paste Special dialog is not that, it doesn't appear. 
> Then Amr marked as duplicate of bug 89453 which is also another issue, to
> improve a wording, not a paste issue. 
> So I set back to Unconfirmed but I'm in favor of confirming to New. Because
> it's a common and important mistake to just paste (with format) and average
> user unfortunately just does that.

And again that would be silly---if we've already done our paste special, then we are going to pop open a dialog, with icon or listing, to pick the format?  And if we've done a simple <Ctrl>+V paste, we're going to be "pestered" with a "what format do you want to paste"?

NO! Our existing mechanism for handling formatting of paste actions is elegant and efficient.  The wording of labeling the available Paste Special formats [1] can be made more meaningful as in bug 89543, otherwise the users need to learn the tool. Pestering with a dialog just gets in the way of productive use--a Microsoft trait.

WONTFIX

=-ref-=
http://opengrok.libreoffice.org/xref/core/sot/source/base/exchange.cxx#46
Comment 11 Cor Nouws 2017-06-14 13:58:54 UTC
(In reply to V Stuart Foote from comment #10)

> And again that would be silly---if we've already done our paste special,
> then we are going to pop open a dialog, with icon or listing, to pick the

it's not a pop up dialog. But - how do they call it - sort of smart tag that fades away?

I agree with your opinion on that things work fine now.
OTOH, for a simple Ctrl+V that thing extra might be useful?

.. I won't fight for this ;)
Comment 12 Timur 2017-06-14 14:13:41 UTC
(In reply to V Stuart Foote from comment #10)
We here are aware of Paste Special (and no questions needed if that is used) but majority of users don't use it at all. 
Pop-up is a great way to draw attention to different paste options and it's not intrusive, it's there in the first moment and if you don't use it it disappears.
Comment 13 V Stuart Foote 2017-06-14 14:37:21 UTC
(In reply to Cor Nouws from comment #11)
> 
> it's not a pop up dialog. But - how do they call it - sort of smart tag that
> fades away?

(In reply to Timur from comment #12)
>
> Pop-up is a great way to draw attention to different paste options and it's
> not intrusive, it's there in the first moment and if you don't use it it
> disappears.

But IIUC, we do not have a "sturcture" available to us for a "smart tag" that opens, allows selection of an action, and then "fades away"...

Rather believe we are limited in doing this cross platform to pop-up dialogs, or tooltip like widgets.  

I really see no reason to waste dev effort to implement such.
Comment 14 Yousuf Philips (jay) (retired) 2017-06-24 22:54:43 UTC
(In reply to Marco A.G.Pinto from comment #0)
> Here is a sketch of how it should look like based on Microsoft's.
> 
> Something like this should appear when one does PASTE into a document.

Would definitely be against such a large size like you have in your mockup, but a smaller one like MSO[1] does make sense only when pasting with Ctrl+V, as it would bring attention to other pasting options for beginners, though dont forget some people will be annoyed by it[2].

[1] https://www.groovypost.com/wp-content/uploads/2011/05/image217.png

[2] https://answers.microsoft.com/en-us/office/forum/office_2007-word/how-do-i-make-the-paste-options-popup-go-away/5eeeaae0-9898-4d43-a5ab-567bfa2759ab

(In reply to Aron Budea from comment #5)
> If you're a novice user who tries to put some data inside a table from Calc
> into Writer, what do you do?

Most novice users will paste as is and change it to their liking, while others who dont want the default pasting will likely paste unformatted text and then change it to how they like it.

> While I agree that having the option of several choices is good (though I'm
> not convinced all of them make a lot of sense in this particular example),
> having a basic dialog with the most meaningful choices that are easy to
> interpret would be extremely helpful, with the option to switch to the
> current, "expert" dialog.

That will hopefully be dealt with in bug 89453.

> Additionally, I believe LibreOffice's choices don't have the "Merge" option
> that is in the suggestion, so the question whether or not that could be
> useful to implement is still open.

Merge has been suggested in bug 83102.

(In reply to V Stuart Foote from comment #13)
> But IIUC, we do not have a "sturcture" available to us for a "smart tag"
> that opens, allows selection of an action, and then "fades away"...

True.

> Rather believe we are limited in doing this cross platform to pop-up
> dialogs, or tooltip like widgets.  

Could be implemented as a floating toolbar with a single button in it, but devs would have to see what is feasible.

> I really see no reason to waste dev effort to implement such.

Personally I agree with you and believe this should be closed as WONTFIX, but if a dev wants to take it on, we shouldnt stop them from doing it, as it does have some benefit for new users.
Comment 15 Heiko Tietze 2017-06-25 17:43:10 UTC
(In reply to Cor Nouws from comment #11)
> it's not a pop up dialog. But - how do they call it - sort of smart tag that
> fades away?

It's a 'floating widget' (closed when focus lost in contrast to the explicit x/close button), and in particular the 'paste options box'.

The use case matters. Marco asks for a dialog that we have, and Timur specifies to 'clearly' or more prominent. I agree with Stuart, Benjamins don't care about paste special and Eves wont accept this fancy thing. 

Btw, this feature is often criticized and one Office FAQ is where to disable this annoyance.
Comment 16 Heiko Tietze 2018-01-12 09:52:24 UTC
Joining the party of comment 8. Bug 89378, comment 10 is my opinion to the request.

*** This bug has been marked as a duplicate of bug 89378 ***